Error trying to install


(hitchhiker) #1

I receive the following error when I begin the installation. I have re-uploaded files to see if this corrects my error, but still receiving the same error. I also verified with my hosting company that I meet all the minimum requirements. The error…

Warning: require_once(/data/20/1/136/85/1951411/user/xxxxx/htdocs/piwik/core/testMinimumPhpVersion.php) [function.require-once]: failed to open stream: No such file or directory in /data/20/1/136/85/1951411/user/xxxxx/htdocs/piwik/index.php on line 66

Fatal error: require_once() [function.require]: Failed opening required ‘/data/20/1/136/85/1951411/user/xxxxx/htdocs/piwik/core/testMinimumPhpVersion.php’ (include_path=’/data/20/1/136/85/1951411/user/xxxxx/htdocs/piwik/core:/data/20/1/136/85/1951411/user/xxxxx/htdocs/piwik/libs:/data/20/1/136/85/1951411/user/xxxxx/htdocs/piwik/plugins’) in /data/20/1/136/85/1951411/user/xxxxx/htdocs/piwik/index.php on line 66

Can someone please help?!


(vipsoft) #2

If you uploaded the files to your host, check that the file exists and is readable. Also, on Unix/Linux hosts, filenames are case-sensitive.


(hitchhiker) #3

Thank YOU… I feel so dumb as I didn’t even notice that the files uploaded all lowercase. Got that corrected and began the installation. I’m getting the following error with the database setup… "Error while trying to connect to the database server: No entry is registered for key ‘db’ " I have set up the user, etc for the mySQL database in my control panel of my hosting company… and have tried everything recommended in other forum posts on this error. Does anyone use Network Solutions and how did they get thru the database portion of the installation?


(vipsoft) #4

Ask your hosting provider since this is system environment specific.

For example, you might have to use 127.0.0.1 instead of localhost, use a Unix socket path (e.g., /var/run/mysqld/mysqld.sock), etc etc etc.