Error on GA4 import

When I try to launch GA4 import, I get this error :
Unexpected error: adding row to table with empty label in Piwik\Plugins\GoogleAnalyticsImporter\Importers\UserCountry\RecordImporterGA4: false

I tried to googled it… but no chance.

We use php 7.4.3 with MySql 10.5.17-MariaDB.
Matomo and the plugin are in the last available version (4.11)

Thanks a lot !

Hi @Kytone,
Have a look at:

Thanks a lot. I saw this post on Github but it seems to be a PHP version issue, and my php version is correct…
(or I did not understand the posts… :slight_smile: )

@Kytone can you check if applying this patch - solves the issue for you ?

1 Like

I’ve just launched the import with this patch, and it seems to work (some data is importing at least)

I’ll check in a few minutes to see how it goes but so far so good.
Thanks a lot !

@Kytone Good to hear about that, all worked fine ?

@Altamash_Shaikh hello
It is working fine !
I marked your answer as the solution !

Thanks a lot !

1 Like