Error message


#1

Since the latest update, when I try to get a report for the month or year for all websites, I get this error message: Fatal error: Maximum execution time of 30 seconds exceeded in /home/catfish/public_html/piwik/core/ArchiveProcessing/Period.php on line 201


(Peterbo) #2

Please have a look at the Piwik FAQ.


#3

Hi,

I see - sorry I failed to check that because I assumed the error message was somehow related to the last update.
Cant access my php.ini because my piwik install is on a shared server. Can I create a separate php.ini that would go in the piwik folder, and if yes, what does it have to contain (sample file for php.ini?). And would I have to put it in all subfolders of the piwik install as well?


(Peterbo) #4

That depends on your server configuration. With mod_php, you can put a .htaccess file in your piwik root folder. If this doen’t run, contact your provider to set this for you. If archiving takes over 30 seconds, you should consider, setting up a cronjob, archiving the data for you: Piwik FAQ