Error message when importing Google Analytics data

I followed Matomo’s guide on importing GA data, and the process was smooth until after uploading the json file. After that, I saw the following error message: “An error occurred. Could not verify the security token on this form”. (Screenshot:


I followed the instructions pretty much to the letter and have encountered no issue or bug on the way until this. I tried contacting support but they didn’t answer. Can anyone help?


Just to be sure: You are using the latest version of Matomo and the plugin, right?

Yes, I am. I’ve recently installed both, so I’m expecting they’re both up to date.

1 Like

I had the same problem. When I tried again, it worked.
Not sure why, but this happened twice. The second time was, because there was some error while importing and I had to authorize it again.
Maybe this helps.

Hi @ErisF, sorry for the trouble, to clarify, this happens when you’re in the authorization workflow, correct? You got to the point where you had to click ‘Authorize’, it took you to google then sent you back to Matomo, or was this before just when uploading the JSON file?

And are you using or self hosting?

Do you mean you did the whole process from scratch?

The bug did occur after I gave authorization to link my domain to Matomo, so after uploading the json file.
I’m using with wordpress, and I installed the plug-in from the plug-in page.

Hi @ErisF, can you email your domain to I’ll see if I can figure out why this is happening. Also can you tell me what browser you’re using?

@ErisF I just realized you might be talking about Matomo for Wordpress (which is different from If you don’t have a domain, did you install Matomo from within Wordpress?

Yes, sorry for the confusion, I’m using Matomo on, and I did install Matomo from Wordpress.

Hi @ErisF, can you tell me what browser you’re viewing Matomo with? And if you have any privacy settings or plugins enabled?

@diosmosis I’m using Firefox and block third party cookies by default.

@ErisF I just created a account, installed matomo, then the importer plugin, and was able to finish authorizing, so I’m guessing there’s something interfering w/ the request from google somewhere on your end.

The quickest workaround would be to downgrade the GoogleAnalyticsImporter plugin to version 4.0.4, then authorize, then upgrade back to the 4.1.3. This would effectively bypass the problem.

If you’d rather not do that and are willing to provide access to your matomo, then I can try and look further into it (in this case send an email to

I will try installing from another browser, then try to downgrade to the previous version of the plugin (how may I do that, actually? How can I download the previous version?), and if nothing works, I’ll send that email to seek further help. I will get a response if I email this address, right? Because when messaging support (or at least what I thought was support) I received no answer.

Thank you for your help.

Just posting here that I responded to your email a couple days ago (just in case it got sent to spam). If you need more help, feel free to comment or send another email.

Recently I check this and everything is ok and please use Latest version for best experience Thanks!!!