Error message : There is no data for this report

Hi,

I have set 4 custom variables, the metrics are getting captured under Visitors -> Custom Variables. But when I select the option ‘Display a table with more metrics’, none of the metrics comes up. It just shows a message “There is not data for this report”.

Any suggestions ??

If i understand you have 4 tracked custom variables, is the error that you want to see more metrics correlated to those custom variables? If so what metrics are you expecting to see?

Yes the error is pertaining to these 4 custom variables. I am trying to see the metrics like Actions, Action per visit, Avg Time on Website and Bounce Rate for these 4 variables.
For more reference, I have attached a snapshot.

Can you increase the timeout in Settings > General Settings > to 1800s or so.

Then does it work better? if nt do you see any error in your server error log file?

Hi Matt,

I tried setting changing the Settings > General Settings to 1800, but that did not work. I also looked into the log files i.e. error.log, Could not find anything relevant, but below are the set of errors which i could locate in the error log.

[error] [client 10.250.129.95] File does not exist: D:/Apache Software Foundation/Apache2.2/htdocs/piwik/themes/logo.png, referer: http://XXXXXXXXXXXXXocal/piwik/index.php?module=CoreAdminHome&action=generalSettings&idSite=1&period=day&date=yesterday

[Wed Nov 21 12:22:05 2012] [error] [client 10.250.129.115] (20024)The given path is misformatted or contained invalid characters: Cannot map GET /piwik%20%3Chttp://XXXXXXXXXXXXXx/piwik/index.php?module=CoreAdminHome&action=generalSettings&idSite=1&period=day&date=yesterday> HTTP/1.1 to file

Please provide some more debugging steps.

please try upgrading to latest beta: http://builds.piwik.org/piwik-1.9.3-b6.zip

does it work betteR?

your first error could be related to a DocumentRoot error found this-

"One of my clients had a similar issue with Apache on Windows. On any request he was getting:

[error] [client 192.168.1.66] File does not exist: D:/apache
I realized that the DocumentRoot was missing form the httpd.conf."

your 2nd error may be related to .htacess file. Would i be correct in guessing you are running a windows server?

also try this in your .htaccess file see if it helps.

php_flag short_open_tag off

Hi Matt and lesjokolat

I upgraded to 1.9.2 and it worked. Thanks a lot for you help.