Error in v3.6.0 B3


#1

Hi
After installing i get the error:

Entry “Piwik\Auth” cannot be resolved: the class is not instantiableFull definition:Object ( class = #NOT INSTANTIABLE# Piwik\Auth scope = singleton lazy = false)

I had to restore from backup to go back to previous build


#2

I’m having exactly the same issue - the only problem is the backup of the database was not done properly, and now it seems I cannot downgrade.

I see 2 options:

  • knowing the steps (SQL queries) to downgrade the database manually back to 3.6.0-b3
  • a manual quickfix of the 3.6.0-b4 code base

Can anyone please help?


#3

Downgraded to 3.6.0-b1 to get the issue go away, only manually changed the version in option table, did not revert the database changes done by b2, 3 and 4


(Lukas Winkler) #4

Hi,

See


and

Do you use any custom login plugins like Google Authentificator?


#5

custom plugins used are

loginldap and bandwidth

anyone has a fix or know why its breaking