Error in Signup page after update Piwik 1.4 --> 1.5


(Razvan) #1

There is an error. Please report the message and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Undefined index: isCustomLogo in /home/director/public_html/Piwik/tmp/templates_c/%%A9^A91^A917CA4A%%header.tpl.php on line 78

Backtrace -->
#0 Piwik_ErrorHandler(8, 1 => ‘Undefined index: isCustomLogo’, 2 => ‘/home/director/public_html/Piwik/tmp/templates_c/%%A9^A91^A917CA4A%%header.tpl.php’, 3 => 78, 4 => array (‘this’ => Piwik_Smarty::__set_state(array(‘template_dir’ => array (0 => ‘/home/director/public_html/Piwik/plugins’, 1 => ‘/home/director/public_html/Piwik/themes/default’, 2 => ‘/home/director/public_html/Piwik/themes’), ‘compile_dir’ => ‘/home/director/public_html/Piwik/tmp/templates_c’, ‘config_dir’ => ‘configs’, ‘plugins_dir’ => array (0 => ‘/home/director/public_html/Piwik/core/SmartyPlugins’, 1 => ‘/home/director/public_html/Piwik/libs/Smarty/plugins’), ‘debugging’ => false, ‘error_reporting’ => ‘6143’, ‘debug_tpl’ => ‘’, ‘debugging_ctrl’ => ‘NONE’, ‘compile_check’ => true, ‘force_compile’ => false, ‘caching’ => 0, ‘cache_dir’ => ‘/home/director/public_html/Piwik/tmp/cache’, ‘cache_lifetime’ => 3600, ‘cache_modified_check’ => false, ‘php_handling’ => 0, ‘security’ => false, ‘secure_dir’ => array (), ‘securit…#1 include(’/home/director/public_html/Piwik/tmp/templates_c/%%A9^A91^A917CA4A%%header.tpl.php’) called at [/home/director/public_html/Piwik/libs/Smarty/Smarty.class.php:1869]#2 Smarty->_smarty_include(array (‘smarty_include_tpl_file’ => ‘Login/templates/header.tpl’, ‘smarty_include_vars’ => array ())) called at [/home/director/public_html/Piwik/tmp/templates_c/%%6E^6E8^6E83E5D4%%register.tpl.php:6]#3 include(’/home/director/public_html/Piwik/tmp/templates_c/%%6E^6E8^6E83E5D4%%register.tpl.php’) called at [/home/director/public_html/Piwik/libs/Smarty/Smarty.class.php:1263]#4 Smarty->fetch(’/home/director/public_html/Piwik/plugins/Signup/templates/register.tpl’) called at [/home/director/public_html/Piwik/core/View.php:138]#5 Piwik_View->render(array () called at [/home/director/public_html/Piwik/plugins/Signup/Controller.php:54]#6 Piwik_Signup_Controller->register(array () called at [/home/director/public_html/Piwik/plugins/Signup/Controller.php:19]#7 Piwik_Signup_Controller->index(array () called at [:]#8 call_user_func_array(array (0 => Piwik_Signup_Controller::__set_state(array(‘pluginName’ => ‘Signup’, ‘strDate’ => NULL, ‘date’ => NULL, ‘idSite’ => 0, ‘site’ => Piwik_Site::__set_state(array(‘id’ => 0)))), 1 => ‘index’), 1 => array ()) called at [/home/director/public_html/Piwik/core/FrontController.php:127]#9 Piwik_FrontController->dispatch(array () called at [/home/director/public_html/Piwik/index.php:53]

What can I do?

Razvan


(Matthieu Aubry) #2

Please post the messae in the signup plugin page in trac


(Razvan) #3

Hello,matt

I posted this message in the signup plugin page in trac.

Razvan


#4

By the upgrade you must copy the full “config” folder!


(Razvan) #5

Hello,

I used this tcket: Piwik as a self serve hosted web analytics solution · Issue #1148 · matomo-org/matomo · GitHub and now Signup page work fine.

Thanks,
Razvan