Error in 1.7 Beta


#1

Hi Matt \ All,
I downloaded the 1.7 Beta and so far it is logging the Adwords campaign “conversions” really well and seems to have fixed the problem - will confirm in a couple of days.

I can make an error appear if I go into “settings” in the top right, and then click the “Websites” tab.

Details below, hope it helps. Everything else is well though. I was trying to change from $ to £ at the time.

Regards,
Paul

There is an error. Please report the message and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Undefined variable: mySites in /home/paul/public_html/piwik/plugins/SitesManager/Controller.php on line 29

Backtrace -->
#0 Piwik_ErrorHandler(…) called at [/home/paul/public_html/piwik/plugins/SitesManager/Controller.php:29]#1 Piwik_SitesManager_Controller->index(…) called at [:]#2 call_user_func_array(…) called at [/home/paul/public_html/piwik/core/FrontController.php:138]#3 Piwik_FrontController->dispatch(…) called at [/home/paul/public_html/piwik/index.php:53]

There is an error. Please report the message and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Undefined variable: mySites in /home/paul/public_html/piwik/plugins/SitesManager/Controller.php on line 31

Backtrace -->
#0 Piwik_ErrorHandler(…) called at [/home/paul/public_html/piwik/plugins/SitesManager/Controller.php:31]#1 Piwik_SitesManager_Controller->index(…) called at [:]#2 call_user_func_array(…) called at [/home/paul/public_html/piwik/core/FrontController.php:138]#3 Piwik_FrontController->dispatch(…) called at [/home/paul/public_html/piwik/index.php:53]

There is an error. Please report the message and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Warning: array_values() [function.array-values]: The argument should be an array in /home/paul/public_html/piwik/plugins/SitesManager/Controller.php on line 31

Backtrace -->
#0 Piwik_ErrorHandler(…) called at [:]#1 array_values(…) called at [/home/paul/public_html/piwik/plugins/SitesManager/Controller.php:31]#2 Piwik_SitesManager_Controller->index(…) called at [:]#3 call_user_func_array(…) called at [/home/paul/public_html/piwik/core/FrontController.php:138]#4 Piwik_FrontController->dispatch(…) called at [/home/paul/public_html/piwik/index.php:53]


(Matthieu Aubry) #2

Good to hear the beta works better for campaign tracking!!

THe bug is already fixed in svn, stay tuned for next betas


#3

Hi Matt,
I found a buglet in the Beta 1.7 version, tracking still working so far though.

The buglet I found was, if you go to Refferers > Campaigns and click a campaign (I only have one Adwords one at the moment), with or without the goal metrics select, and then change the daterange from “today” (day), to “week”, it still shows the statistics for the day, not a cumulative of the week. I haven’t been able to check month\year yet.

I was always good at testing and breaking things, hope that helps :slight_smile: (it could be “user error” at my end though :wink: )

Best Regards,
Paul


(Matthieu Aubry) #4

Maybe because it was monday and week = day in this case? test a different week?