Error after upgrade to 2.14.0, no column


#1

After upgrading to 2.14.0 all dashboard widgets state this:

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘log_visit.config_os’ in ‘field list’

I saw some fixes via phpMyAdmin, but none seemed to be for the above one.

Thanks


(Matthieu Aubry) #2

Hi there,

please try the workaround at: 301 Moved Permanently


#3

Thanks.

Unfortunatelly, none of that adresses column ‘log_visit.config_os’ in ‘field list’

I must comment that Piwik has gone a long way (all positive). The scale of its usage prompts that a beginer has to be able to implement it without such hasle.

Thanks


(Matthieu Aubry) #4

Try ALTER TABLE piwik_log_visit ADD COLUMN config_os char(3) NOT NULL;


#5

Thanks.

Unfortunately, widgets still show:

SQLSTATE[42S22]: Column not found: 1054 Unknown column ‘log_visit.config_browser_name’ in ‘field list’

:confused:


(Matthieu Aubry) #6

IT seems your Piwik tables don’t have a prefix, so try:

ALTER TABLE log_visit ADD COLUMN config_os char(3) NOT NULL;


#7

I got this error.
The workaround helped only a little bit.
“WARNING: … piwik/plugins/UserLanguage/Visitor.php(24): Notice - Undefined index: location_browser_lang - Piwik 2.14.0 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)”

In the widgets is written: Mysqli prepare error: Unknown column ‘log_visit.location_browser_lang’ in ‘field list’

I use a prefix.


#8

Yes, they do have a prefix (piwik_).

In this case it was about config_browser_name. After entering that, Piwik now complains about config_browser_version.

Why are all this columns missing?


#9

Hi everybody,
I got the same error. I triggered the mysql command:
ALTER TABLE piwik_log_visit ADD COLUMN location_browser_lang VARCHAR(20) NOT NULL;
It is important to list the database tables to see the prefix. In my case wa piwik_


#10

It is important to list the database tables to see the prefix.

Thanks. As an OP, that was not a problem in my case anyway. It’s a bunch of missing columns. As I fix one, another one comes up. That’s the question waiting for an answer. Why so many?


#11

Would anyone by now be able to explain why so many columns are missing?

Thanks


(Matthieu Aubry) #12

Hi there,

this is a bug, we will investigate it ASAP see Column not found: 1054 Unknown column 'log_visit.location_browser_lang' in 'field list'" · Issue #8304 · matomo-org/piwik · GitHub


#13

Thanks.

I suppose this latest 2.14.1 update did not include the fix for this particular problem. Is that correct, please?

Thank you


(Matthieu Aubry) #14

The next 2.14.2 will include the fix for this issue. it will be released in the coming days.