Error after Upgrade 1.3->1.5


#1

After upgrading from 1.3 to 1.5 I receive this error:


Notice: Undefined index: branding in /var/www/****.com/piwik15/core/Config.php on line 336

Backtrace -->
#0 Piwik_ErrorHandler(8, 1 => 'Undefined index: branding', 2 => '/var/www/****.com/piwik15/core/Config.php', 3 => 336, 4 => array ('name' => 'branding')) called at [/var/www/****.com/piwik15/core/Config.php:336]#1 Piwik_Config->__get('branding') called at [/var/www/****.com/piwik15/core/Controller.php:377]#2 Piwik_Controller->setBasicVariablesView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_d...#3 Piwik_Login_Controller->configureView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_dir...#4 Piwik_Login_Controller->login(array () called at [/var/www/****.com/piwik15/plugins/Login/Controller.php:28]#5 Piwik_Login_Controller->index(array () called at [:]#6 call_user_func_array(array (0 => Piwik_Login_Controller::__set_state(array('pluginName' => 'Login', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'index'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#7 Piwik_FrontController->dispatch('Login', 1 => false) called at [/var/www/****.com/piwik15/core/Controller.php:476]#8 Piwik_Controller->redirectToIndex('CoreHome', 1 => 'index', 2 => NULL) called at [/var/www/****.com/piwik15/plugins/CoreHome/Controller.php:42]#9 Piwik_CoreHome_Controller->redirectToCoreHomeIndex(array () called at [:]#10 call_user_func_array(array (0 => Piwik_CoreHome_Controller::__set_state(array('pluginName' => 'CoreHome', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'redirectToCoreHomeIndex'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#11 Piwik_FrontController->dispatch(array () called at [/var/www/****.com/piwik15/index.php:53]

and


Notice: Trying to get property of non-object in /var/www/****.com/piwik15/core/Controller.php  on line 377

Backtrace -->
#0 Piwik_ErrorHandler(8, 1 => 'Trying to get property of non-object', 2 => '/var/www/****.com/piwik15/core/Controller.php', 3 => 377, 4 => array ('view' => Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik...#1 Piwik_Controller->setBasicVariablesView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/***.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_d...#2 Piwik_Login_Controller->configureView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_dir...#3 Piwik_Login_Controller->login(array () called at [/var/www/****.com/piwik15/plugins/Login/Controller.php:28]#4 Piwik_Login_Controller->index(array () called at [:]#5 call_user_func_array(array (0 => Piwik_Login_Controller::__set_state(array('pluginName' => 'Login', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'index'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#6 Piwik_FrontController->dispatch('Login', 1 => false) called at [/var/www/****.com/piwik15/core/Controller.php:476]#7 Piwik_Controller->redirectToIndex('CoreHome', 1 => 'index', 2 => NULL) called at [/var/www/****.com/piwik15/plugins/CoreHome/Controller.php:42]#8 Piwik_CoreHome_Controller->redirectToCoreHomeIndex(array () called at [:]#9 call_user_func_array(array (0 => Piwik_CoreHome_Controller::__set_state(array('pluginName' => 'CoreHome', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'redirectToCoreHomeIndex'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#10 Piwik_FrontController->dispatch(array () called at [/var/www/****.com/piwik15/index.php:53]

and


Notice: Undefined index: branding in /var/www/****.com/piwik15/core/Config.php  on line 336

Backtrace -->
#0 Piwik_ErrorHandler(8, 1 => 'Undefined index: branding', 2 => '/var/www/****.com/piwik15/core/Config.php', 3 => 336, 4 => array ('name' => 'branding')) called at [/var/www/****.com/piwik15/core/Config.php:336]#1 Piwik_Config->__get('branding') called at [/var/www/****.com/piwik15/plugins/API/API.php:319]#2 Piwik_API_API->getHeaderLogoUrl(array () called at [/var/www/****.com/piwik15/core/Controller.php:378]#3 Piwik_Controller->setBasicVariablesView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_d...#4 Piwik_Login_Controller->configureView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_dir...#5 Piwik_Login_Controller->login(array () called at [/var/www/****.com/piwik15/plugins/Login/Controller.php:28]#6 Piwik_Login_Controller->index(array () called at [:]#7 call_user_func_array(array (0 => Piwik_Login_Controller::__set_state(array('pluginName' => 'Login', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'index'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#8 Piwik_FrontController->dispatch('Login', 1 => false) called at [/var/www/****.com/piwik15/core/Controller.php:476]#9 Piwik_Controller->redirectToIndex('CoreHome', 1 => 'index', 2 => NULL) called at [/var/www/****.com/piwik15/plugins/CoreHome/Controller.php:42]#10 Piwik_CoreHome_Controller->redirectToCoreHomeIndex(array () called at [:]#11 call_user_func_array(array (0 => Piwik_CoreHome_Controller::__set_state(array('pluginName' => 'CoreHome', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'redirectToCoreHomeIndex'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#12 Piwik_FrontController->dispatch(array () called at [/var/www/****.com/piwik15/index.php:53]

and


Notice: Trying to get property of non-object in /var/www/****.com/piwik15/plugins/API/API.php  on line 319

Backtrace -->
#0 Piwik_ErrorHandler(8, 1 => 'Trying to get property of non-object', 2 => '/var/www/****.com/piwik15/plugins/API/API.php', 3 => 319, 4 => array ('pathOnly' => false, 'logo' => 'themes/default/images/logo-header.png')) called at [/var/www/****.com/piwik15/plugins/API/API.php:319]#1 Piwik_API_API->getHeaderLogoUrl(array () called at [/var/www/****.com/piwik15/core/Controller.php:378]#2 Piwik_Controller->setBasicVariablesView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_d...#3 Piwik_Login_Controller->configureView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_dir...#4 Piwik_Login_Controller->login(array () called at [/var/www/****.com/piwik15/plugins/Login/Controller.php:28]#5 Piwik_Login_Controller->index(array () called at [:]#6 call_user_func_array(array (0 => Piwik_Login_Controller::__set_state(array('pluginName' => 'Login', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'index'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#7 Piwik_FrontController->dispatch('Login', 1 => false) called at [/var/www/****.com/piwik15/core/Controller.php:476]#8 Piwik_Controller->redirectToIndex('CoreHome', 1 => 'index', 2 => NULL) called at [/var/www/****.com/piwik15/plugins/CoreHome/Controller.php:42]#9 Piwik_CoreHome_Controller->redirectToCoreHomeIndex(array () called at [:]#10 call_user_func_array(array (0 => Piwik_CoreHome_Controller::__set_state(array('pluginName' => 'CoreHome', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'redirectToCoreHomeIndex'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#11 Piwik_FrontController->dispatch(array () called at [/var/www/****.com/piwik15/index.php:53]

and


Notice: Undefined index: branding in /var/www/****.com/piwik15/core/Config.php  on line 336

Backtrace -->
#0 Piwik_ErrorHandler(8, 1 => 'Undefined index: branding', 2 => '/var/www/****.com/piwik15/core/Config.php', 3 => 336, 4 => array ('name' => 'branding')) called at [/var/www/****.com/piwik15/core/Config.php:336]#1 Piwik_Config->__get('branding') called at [/var/www/****.com/piwik15/plugins/API/API.php:302]#2 Piwik_API_API->getLogoUrl(array () called at [/var/www/****.com/piwik15/core/Controller.php:379]#3 Piwik_Controller->setBasicVariablesView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_d...#4 Piwik_Login_Controller->configureView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_dir...#5 Piwik_Login_Controller->login(array () called at [/var/www/****.com/piwik15/plugins/Login/Controller.php:28]#6 Piwik_Login_Controller->index(array () called at [:]#7 call_user_func_array(array (0 => Piwik_Login_Controller::__set_state(array('pluginName' => 'Login', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'index'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#8 Piwik_FrontController->dispatch('Login', 1 => false) called at [/var/www/****.com/piwik15/core/Controller.php:476]#9 Piwik_Controller->redirectToIndex('CoreHome', 1 => 'index', 2 => NULL) called at [/var/www/****.com/piwik15/plugins/CoreHome/Controller.php:42]#10 Piwik_CoreHome_Controller->redirectToCoreHomeIndex(array () called at [:]#11 call_user_func_array(array (0 => Piwik_CoreHome_Controller::__set_state(array('pluginName' => 'CoreHome', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'redirectToCoreHomeIndex'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#12 Piwik_FrontController->dispatch(array () called at [/var/www/****.com/piwik15/index.php:53]

and


Notice: Trying to get property of non-object in /var/www/****.com/piwik15/plugins/API/API.php  on line 302

Backtrace -->
#0 Piwik_ErrorHandler(8, 1 => 'Trying to get property of non-object', 2 => '/var/www/****.com/piwik15/plugins/API/API.php', 3 => 302, 4 => array ('pathOnly' => false, 'logo' => 'themes/default/images/logo.png')) called at [/var/www/****.com/piwik15/plugins/API/API.php:302]#1 Piwik_API_API->getLogoUrl(array () called at [/var/www/****.com/piwik15/core/Controller.php:379]#2 Piwik_Controller->setBasicVariablesView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_d...#3 Piwik_Login_Controller->configureView(Piwik_View::__set_state(array('template' => '/var/www/****.com/piwik15/plugins/Login/templates/login.tpl', 'smarty' => Piwik_Smarty::__set_state(array('template_dir' => array (0 => '/var/www/****.com/piwik15/plugins', 1 => '/var/www/****.com/piwik15/themes/default', 2 => '/var/www/****.com/piwik15/themes'), 'compile_dir' => '/var/www/****.com/piwik15/tmp/templates_c', 'config_dir' => 'configs', 'plugins_dir' => array (0 => '/var/www/****.com/piwik15/core/SmartyPlugins', 1 => '/var/www/****.com/piwik15/libs/Smarty/plugins'), 'debugging' => false, 'error_reporting' => '30719', 'debug_tpl' => '', 'debugging_ctrl' => 'NONE', 'compile_check' => true, 'force_compile' => false, 'caching' => 0, 'cache_dir' => '/var/www/****.com/piwik15/tmp/cache', 'cache_lifetime' => 3600, 'cache_modified_check' => false, 'php_handling' => 0, 'security' => false, 'secure_dir...#4 Piwik_Login_Controller->login(array () called at [/var/www/****.com/piwik15/plugins/Login/Controller.php:28]#5 Piwik_Login_Controller->index(array () called at [:]#6 call_user_func_array(array (0 => Piwik_Login_Controller::__set_state(array('pluginName' => 'Login', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'index'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#7 Piwik_FrontController->dispatch('Login', 1 => false) called at [/var/www/****.com/piwik15/core/Controller.php:476]#8 Piwik_Controller->redirectToIndex('CoreHome', 1 => 'index', 2 => NULL) called at [/var/www/****.com/piwik15/plugins/CoreHome/Controller.php:42]#9 Piwik_CoreHome_Controller->redirectToCoreHomeIndex(array () called at [:]#10 call_user_func_array(array (0 => Piwik_CoreHome_Controller::__set_state(array('pluginName' => 'CoreHome', 'strDate' => NULL, 'date' => NULL, 'idSite' => 0, 'site' => Piwik_Site::__set_state(array('id' => 0)))), 1 => 'redirectToCoreHomeIndex'), 1 => array ()) called at [/var/www/****.com/piwik15/core/FrontController.php:127]#11 Piwik_FrontController->dispatch(array () called at [/var/www/****.com/piwik15/index.php:53]

All on the same login-page.

The only modification made was installing Clickheat. Even after disabling it the problem persists.
Anybody with an advise to solve this problem?


#2

same issue ! from 1.4.x to 1.5

only plugins is GeoIP


(Matthieu Aubry) #3

I think in your case, the problem is that the config/global.ini.php was not uploaded/overwritten properly during the upgrade. Check there are no other files with the same problem.


#4

How could I generate the right one ?


#5

Problem was solved for me by uploading the global.ini.php from a fresh downloaded 1.5-package.
Thanks for your help!


#6

On my side, I just solved it by hacking my config also… I had to remove temporarly GeoIP…but, this is not a real problem


(vipsoft) #7

You should never edit global.ini.php because we periodically make changes to it. config.ini.php contains your settings which override those in global.ini.php.

However, for the auto-update and plugin activation/deactivation to work, both files need to be writeable.