Error after updating to 2.12.0


#1

Hello,

Update Piwik today to 2.12.0 (automatic update) - now, tracking is not working anymore but this error appears instead:

 [Tue Mar 24 21:31:25 2015] [error] PHP Fatal error:  Call to undefined method Piwik\\IP::isIPv4() in [PATH]/plugins/IPv6Usage/IPv6Usage.php on line 96 

There are no new entries @ p_log_visit anymore since the update. Do you have any idea how to get Piwik back to work?

In addition (but not so important at the moment): before the update, when going to “All Websites”, at the top-right there was something like “You have installed Piwik x. xx” or “A new version is available”. It is gone as well. Was it intentional or is this an error as well?

Thank you!


(Matthieu Aubry) #2

Hi there,

please upgrade the plugin IPv6Usage with the latest version from the Marketplace, which should fix it!


#3

Hi Matt,

Thanks a lot - it works & for your ultra-fast response.

Concerning updates to come and plugins: do I have to expect incompatible plugins are not automatically deactivated again? So, should I have a look after every update into the plugin list? Until now I was not expecting plugins causing error after updates.

Cheers,
Robert


(Matthieu Aubry) #4

When a plugin causes an error in this way, and you visit Piwik UI, there should be the “Safe mode” displayed, which lets you disable the plugin that causes the error. when you visited the UI you didn’t see this screen maybe?


#5

I haven’t noticed such a “Safe mode” message. Maybe my fault, maybe it was not there - to judge this, I will describe you, what I have done and what I have seen:

Being logged in into Pwik UI, I was on “All Websites” and clicked on the link “update now” (top right). It sends me to the update page, where it downloaded and installed Pwik updates and offered me the link to go back to Piwik UI. I clicked this link and came back to “All Websites”. There was no message. I logged out.
Later I found no more visits are tracked, wrote here, got your answer, went into administration->plugins, found the option to update and updated IPv6Usage-plugin. All the way, I didn’t see any notice telling me, something might be wrong.
After updating and finding the problem is solved, I found a possible update for the InterSites-plugin. So I updated it and, afterwards, got the message - all over on top of every single page - I had to update a certain config-file as well to get it run again after the update. So, I updated this config-file as described, logged out and in straight afterwards and found this message gone.

Maybe you can decide out of this, if I was right and there was no “safe mode” message as it should be or if I am wrong and did not see this message.

Kind regadrs,
Robert


#6

Hi, Google sent me here when I saw the same error in my logs after updating to 2.12. I can confirm updating the IPv6Usage plugin solved this for me however, like Jappie, I did not see a “Safe mode” or any other notice. I don’t check my analytics daily - more like monthly actually - and chance are I would not have noticed this if I wasn’t debugging another script. It would be great if in the future I would not stumble upon this accidentally but get a notification.


(Matthieu Aubry) #7

Thanks for confirming. I’ve created an issue so we take a look at it sometime: How to detect any failure during Tracker requests and pro-actively inform Piwik admin of such error · Issue #7550 · matomo-org/piwik · GitHub


(Youlike) #8

update the newest IPv6Usage


(Matthieu Napoli) #9

FYI you didn’t see the safemode because the error happened in the tracker requests (where the Ipv6 plugin is called), not in the Piwik interface. We are discussing that problem in the GitHub issue.