Error after update to 2.14.0


#1

I tried automatically updating to version 2.14.0 as prompted by piwik this morning. After clicking update automatically the page hung while it was loading and stayed loading for a number of minutes. FInally I just refreshed the page and now I get this error

“Class Piwik\Measurable\Type\TypeManager does not exist”

every time I try to log into Piwik. Nothing is working anymore. Please help!

Thanks!


#2

mine has also failed… but with a different error message:

An exception has been thrown during the rendering of a template ("!important is undefined: failed at !important; line: 7910") in “@CoreUpdater/runUpdaterAndExit_welcome.twig” at line 8.


(Bruce) #3

Mine also failed with yet another different error.

WARNING: /home/content/20/8334020/html/piwik/plugins/UserLanguage/Visitor.php(29): Notice - Undefined index: location_browser_lang - Piwik 2.14.0 - Please report this message in the Piwik forums: http://forum.piwik.org (please do a search first as it might have been reported already)


#4

Had the same problem.

Just fixed it by loggin in, going to Administration and update all the plugins (in my case there were two that needed updating).

Update:
Ai… or not… after reloading the dasboard, the error “Notice - Undefined index: location_browser_lang - Piwik 2.14.0” is back. Probably another plugin.
If you scroll waaaay down, the dashboard is visible.


#5

I have a similar problem as “tunist” here in this thread:

"An exception has been thrown during the rendering of a template (“The ui asset with ‘href’ = /var/www/web188/html/piwik_new/plugins/Morpheus/stylesheets/main.less is not readable” ) in “@CoreUpdater/runUpdaterAndExit_welcome.twig” at line 8.

Unfortunately no logging in possible.
What shall I do now?
Thanks for help!


#6

I have a very big problem too since this update !!

Look at this : 301 Moved Permanently


(Matthieu Aubry) #7

@PraeSenZ did you use manual update or automatic update? Anyway you can fix the issue by reuploading the piwik files as it looks like some files are not uploaded correctly


#8

I did the update manually. The manual update could solve problems with files that can’t be opened.

Still… I get a lot of database errors like this one:
‘log_visit.location_browser_lang’ in ‘field list’

Update:
Okay. I did the following. I downloaded the latest version of Piwik, uploaded all the files in binary mode and overwritten all the existing files. The I followed this link:
https://piwik.org/faq/how-to-update/#faq_179

And updated the version in the database to version 1.x. Then Piwik told me an upgrade was needed and did the update. After that still no luck. Still have the same database errors.

Update 2:
Alright I disabled the following plugins:
PerformanceMonitor
UserLanguage

And now I’m error free (well… at least my Piwik installation is)


#9

thanks, Matt. Yes, a manual update was the solution.

In general, should one / I prefer this method in the future??


#10

i ran through the manual update procedure, but the problems remain here. i:

[ul]
[li] put the site into maintenance mode (which didn’t work correctly)
[/li][li] manually downloaded the latest piwik files and overwrote the version on my server with them
[/li][li] ran the SQL update to the database which reverts the core version to the level it was prior to the upgrade (which didn’t work… and i got an SQL error. i checked the version number manually and it was still set to the older version number anyway).
[/li][li] i then attempted to view the piwik error screen / login screen and now see an nginx 503 error page instead. there is nothing being written to the PHP log when i view this page and see this error screen.
[/li][/ul]

anyone got any more ideas ?


(Matthieu Aubry) #11

@tunist, I’m wondeirng what is the problem as well, I don’t get it so far. Maybe try to remove “UserLanguage” from your config/config.ini.php file?


(Bruce) #12

I disabled 'UserLanguage" looks better then the original disaster, but now I have no data since this issue from visits. And it looks broken still. Driving me nuts, had a problem last time as well during an update.

~B


(Matthieu Aubry) #13

Bruce, what looks broken still? is your Piwik collecting data now?


#14

Hi,

I have the same probs as Bruce[/url][/b] and [b][url=http://forum.piwik.org/read.php?2,127826,page=1#msg-127844]dib0

Also I noticed since upgrading from 2.13.0 to 2.14.0, that the tracking is completle gone (on all upgraded Piwik systems).

:S

Regards,
Barcelo


(Bruce) #15

Matt I am trying to upload all files again to piwik folder, GRrrrrr… tried twice, still get error…

File integrity issues, trying like 3 times. Jees!

Tired of these issues…


(Matthieu Aubry) #16

Are you uploading in BINARY mode in your ftp software?

best solutoin would be to use SSH and unpack the ZIp file. it’s much faster this way.

Regarding tracking not working, that’s not good: do you see any error in your server error log?


(Bruce) #17

Matt - I never could figure out how to do this with SSH, as far as I can tell I am using binary yah. I checked settings, tried three times. Has to be a way to sllve this.

I get this… how to solve?

File size mismatch: /home/content/20/8334020/html/piwik/libs/bower_components/jquery.scrollTo/jquery.scrollTo.min.js (expected length: 2712, found: 2706)
Missing file: /home/content/20/8334020/html/piwik/libs/jquery/gpl-3.0.txt
File size mismatch: /home/content/20/8334020/html/piwik/libs/pChart/class/pData.class.php (expected length: 31449, found: 30661)
File size mismatch: /home/content/20/8334020/html/piwik/libs/pChart/class/pDraw.class.php (expected length: 327671, found: 321446)
File size mismatch: /home/content/20/8334020/html/piwik/libs/pChart/class/pImage.class.php (expected length: 20477, found: 19996)
File size mismatch: /home/content/20/8334020/html/piwik/libs/pChart/class/pPie.class.php (expected length: 67069, found: 65570)
File size mismatch: /home/content/20/8334020/html/piwik/libs/pChart/GPLv3.txt (expected length: 35823, found: 35148)
File size mismatch: /home/content/20/8334020/html/piwik/libs/pChart/readme.txt (expected length: 12528, found: 12386)
Missing file: /home/content/20/8334020/html/piwik/misc/gpl-3.0.txt

Also I can’t get this file to goto the server, it wont move no matter what I do.
Missing file: /home/content/20/8334020/html/piwik/libs/jquery/gpl-3.0.txt


#18

I too have an error after updting to 2.14.0. Error message I get when I try to load any page of Piwik is:


An exception has been thrown during the rendering of a template ("The ui asset with 'href' = /homepages/27/d231218971/htdocs/eyeontaiwan.com/piwik/plugins/Morpheus/stylesheets/main.less is not readable") in "@CoreUpdater/runUpdaterAndExit_welcome.twig" at line 5.

Does anybody at Piwik ever put these updates through a QA process? I’m glad I didn’t buy the pro version.


#19

Hi,

I’m really kind of lost a bit… as tracking stopped working. ::o

Is there a way to downgrade / roll back to V 2.13.0 ?

F.e.:
Upload the files of V 2.13.0 and set in the database the version to 1.X to get the database update ?

Regards,
Barcelo


#20

All my tracking is down too, a rollback process would be good (database and files) I did the files but the database is in 2.14