Erreur de connexion à l'interface Piwik


#1

Bonjour,

Je rencontre depuis hier après midi un problème sur mon interface PIWIK.
En effet, je ne parviens pas à m’y connecter.
Lorsque je tape mon mot de passe, j’ai dans un cadre rouge clair, le message d’erreur suivant :

Erreur: La sécurité du formulaire a échoué. Veuillez recharger le formulaire et vérifier que vos cookies sont activés. Si vous utilisez un serveur proxy, vous devez configurer Piwik pour accepter les en-têtes du proxy qui relaient les en-têtes de l’hôte. Vérifiez aussi que l’en-tête de votre référent est correctement transmis.

suivi s’un autre message dans un cadre jaune :

There is an error. Please report the message (Piwik 2.9.1) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Warning: session_write_close(): Failed to write session data (files). Please verify that the current setting of session.save_path is correct (/chemin/piwik/tmp/sessions) in /chemin/piwik/libs/Zend/Session.php on line 691

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [:]
#1 session_write_close(…) called at [/chemin/piwik/libs/Zend/Session.php:691]
#2 Zend_Session::writeClose(…) called at [:]

Es ce que quelqu’un a déja eu ce type de problème ?


(Matthieu Napoli) #2

Salut,

Est-ce suite à une MAJ ? Est-ce que le chemin en question (/chemin/piwik/tmp/sessions) existe et est “writable” ?


#3

Bonjour,

C’est suite à une mise à jour automatique vers la dernière version de piwik (2.9.1) mais également
une modification dans les fichiers de conf de haproxy et piwik pour permettre a piwik de recevoir
les vrais adresses IP des visiteurs et non celle du proxy.

Tout semblait fonctionner correctement mais une fois deconnecter j’ai eu ces messages d’erreurs le
lendemain.

dans haproxy.cfg

defaults
log global
mode tcp
option forwardfor except 127.0.0.1

listen balancer xxx.xxx.xxxx.xxx:80
mode http
option tcplog
option forwardfor
option http-server-close

dans config.ini.php de piwik

[General]

; Uncomment line below if you use a standard proxy
;proxy_client_headers[] = "HTTP_X_FORWARDED_FOR"
proxy_host_headers[] = “HTTP_X_FORWARDED_HOST”

; Uncomment line below if you use CloudFlare
;proxy_client_headers[] = “HTTP_CF_CONNECTING_IP”

; Uncomment line below if you use another proxy (that sets Client-IP header)
proxy_client_headers[] = “HTTP_CLIENT_IP”

Enfin, “/chemin/piwik/tmp/sessions” existe et est bien “writable”


(Matthieu Aubry) #4

Salut, peux tu verifier: Please verify that the current setting of session.save_path is correct

dans le php.ini ?