Enabling delete_logs_enable

Hi, in my matomo_options table I have delete_logs_enable = 1 and delete_logs_older_than = 30.
But when I go to Anonymize data part of admin ui, the Regularly delete old raw data checkbox is unclicked. When I click it though, the form input Delete logs older than (days) is made visible and my value (30) is showing there.

Is this expected? That the checkbox is unclicked even though the setting is actually enabled.
Or is the setting in fact not enabled? I will know in a few days when I have ran Matomo for 30+ days.

Hi @sandin
Is it the bug described below?

If so, then it will be fixed in the next release… (4.12.4)

Yes! Thank you, good info there.