Enable Error Reporting

Just clicked the update button on my Piwik and now I’m seeing 500 Server error message with no useful PHP error reporting showing up.

I run a php-errors.log file but for some reason Matomo / Piwik isn’t writing anything into this log. I’ve enabled debug and even tried on-demand-debug and still nothing.

I need a useful error message to see WTH is going on now.

I thought these issues were solved… ie, everytime you update it kills the system.

This is a production environment and I’m supposed to be presenting custom action tracking in 1 hour!!! So pissed right now!!

Any help?

Hi,

The php error log isn’t created by Matomo but by PHP so you’ll need to check your php.ini if it is logging correctly.

If you wan’t PHP errors to appear in your browser, you can (temporarily) enable display_errors in your php.ini

Hi Lukas…

Is there any current issues with the current version and PHP7.1 (FastCGI module on Ubuntu 16)

I can’t get it to display anything other than:

Internal Server Error
The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@localhost to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Apache/2.4.29 (Ubuntu) Server at www.lubrigard.com Port 443

https://www.lubrigard.com/piwik/index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday

Hi,
PHP 7.1 is definitely supported.

https://www.lubrigard.com/piwik/ is also loading correctly for me.

The login page does load, but once you log in it does not. I could give you my pw… I think I’m just going to start a new installation for now cuz I have this meeting in 1 hour!!

Can’t you enable more php logging temporarily to find out what’s the error?

That’s what i’ve been trying to do. Its possible this is not a PHP error but an Apache error, cuz nothing is showing from PHP… i enabled full logging… I’m a backend developer … i know how to debug, its just not working. Was hoping you maybe had seen this kind of thing before.

Where can I find prior versions?

https://builds.matomo.org/

Old version didn’t work… I did a fresh install. :frowning: :frowning:

I’m redefining my sites, and making sure they use the same siteId. Is there a defined procedure to import my tracking data from db piwik1 to piwik2 ?

The intended way of importing data is simply using the same database on install

I see, I did try that first, however the same error persisted. This happened when I used the internal auto-updater to update.