Email reports -timeouts


#1

following the upgrade to 1.7/1.7.1 I can no longer issues reports by email/PDF. I think I’ve tracked this down to PHP script time outs. Currently set at 340 seconds and failing.

my questions is, has something changed to make this happen (why did it work before), and why can’t the email reports make use of auto-archiving so it should be a pretty quick send. OR, does some new feature change something?

Messing about with less items on the report/html doesn’t see to have fixed it.

Is it possible to have just this page / functionality execute with a larger time-out?

thanks


(Matthieu Aubry) #2

Make sure you setup: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo
and then it should work?


#3

this is setup and runs every hour. Have also updated with the extra parameter to specify path to Piwik. Seems to be working ok, last results below. A t one point, before I deleted all email jobs and recreated, we were getting the last 1 days report, rather than the week. After recreating the jobs, it now always times out. Have increased to 460 seconds, with no luck. What am I missing?

[2012-02-29 12:41:06] [9678e108] Done archiving!
[2012-02-29 12:41:06] [9678e108] ---------------------------
[2012-02-29 12:41:06] [9678e108] SUMMARY
[2012-02-29 12:41:06] [9678e108] Total daily visits archived: 10296
[2012-02-29 12:41:06] [9678e108] Archived today’s reports for 30 websites
[2012-02-29 12:41:06] [9678e108] Archived week/month/year for 30 websites.
[2012-02-29 12:41:06] [9678e108] Skipped 8 websites: no new visit since the last script execution
[2012-02-29 12:41:06] [9678e108] Skipped 0 websites day archiving: existing daily reports are less than 3600 seconds old
[2012-02-29 12:41:06] [9678e108] Skipped 0 websites week/month/year archiving: existing periods reports are less than 3600 seconds old
[2012-02-29 12:41:06] [9678e108] Total API requests: 120
[2012-02-29 12:41:06] [9678e108] done: 30/30 100%, 10296 v, 30 wtoday, 30 wperiods, 120 req, 585937 ms, no error
[2012-02-29 12:41:06] [9678e108] Time elapsed: 585.937s
[2012-02-29 12:41:06] [9678e108] ---------------------------
[2012-02-29 12:41:06] [9678e108] SCHEDULED TASKS
[2012-02-29 12:41:06] [9678e108] Starting Scheduled tasks…
[2012-02-29 12:41:06] [9678e108] No task to run
[2012-02-29 12:41:06] [9678e108] done


#4

does anyone have any ideas on this?

If I’m auto-archiving every hour, there’s no need for the email report to build the stats, just issue the report surely?


(Matthieu Aubry) #5

sending the report requires the stats to be processed since the reports contain the stats (or at least, could potentially use them, that’s why we send reports after processing stats)


#6

I don’t understand why they need to be re-run though? Am I really going to have to increase the timeout to 585+ seconds? That can’t be healthy? I’m no php/mysql guru, but that sounds wrong if you’re sending 10+ reports on a monday for the previous week?

Is there a reason why it’s worse since the recent (2) updates? Does the new graphing make it slower/take longer?


(Matthieu Aubry) #7

Yes you’re right, it’s probably the graphs, that should be the only thing that changed. If you can test, disable GD extension in PHP and restart webserver. Then reports will not contain graphs. Does it work then?

PS: reports do not have to re-processed when sending the emails, it will just load the reports when they are already processed ,which should be very fast