Email reports not sent in 1.7.1


#1

Hello !

Sorry for my bad english.

Since 1.7 I have some bugs with traduction: new features still in english… How can I download tranlation for that?

Since 1.7 report aren’t send, how can I fix that?

Thank you for your help
Dano


#2

Please help me reports aren’t send since update with version 1.7 !!!


(Matthieu Aubry) #3

update to 1.7.1


#4

Subject is “Bugs with 1.7.1” so I have 1.7.1 but with 1.6 all worked fine :frowning:


(Matthieu Aubry) #5

Have you setup: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo ?


#6

I don’t want to archive my reports… Just send them by email…

Before my updtae for 1.7 all worlks fine.
With 1.7 no emails reports so I tried 1.7.1 but still no emails reports send automatically.

When I tried manually it works so isn’t a problem with email function I think…


(Matthieu Aubry) #7

If you send me your bug report + FTP logins/pwd to Piwik + piwik URL + piwik login/pwd at matt@piwik I will try to investigate!


#8

Ok just tell me where I can find the bug report…


(Matthieu Aubry) #9

I mean, a full description of the bug experienced


#10

Ok I will try but my english is bad :frowning:

Few months ago I’ve installed Piwik 1.6 for analyse 10 websites for clients.
When I set accounts I configured piwik for sent PDF reports by email each months for each client.

All worked fine since I upgrade to 1.7.
At this time no emails reports were sent.

I upgrade to 1.7.1 but same problem.
No email is sent :frowning:

For testing I configure piwik for send PDF report by email each day, with php function and SMTP, but it doesn’t work…

Hope you can understand that :frowning:


(Matthieu Aubry) #11

Please try to disable graphs from the reports, as explained in this forum post:
http://forum.piwik.org/read.php?2,85828,page=1#msg-86756

After disabling graphs completely, and wait 24 hours for daily reports, does it work or is it still not working?


#12

Ok I have disable graph in reports by set default value in “Display options”.
I’ll tell tomorrow if it works… I hope


(Matthieu Aubry) #13

You need to apply the patch to completely disable all graphs, otherwise some graphs will still be displayed: 301 Moved Permanently


#14

Oh sorry I didn’t see your last message :frowning:
But it works without the patch…

Do you think this problem will be fix in the next version?


#15

But there is something strange : when I set reports with grahs it doesn’t work automatically but manually it works…