Does Piwik 2.11.1 require PHP 5.4?



in the list of requirements, it is said that Piwik should work with PHP 5.3.3 until May 2015.

Today I updated six Piwik installations for several customers from version 2.10 to version 2.11.1. After the update, one of the installations didn’t show any widgets. I tried several things including a restore from a backup and trying again, and I compared the installation with one of those that worked just fine. Only when I switched the PHP version from 5.3.28 to 5.4.30, Piwik worked again.

I can’t switch to the newer version permanently yet, since the customer uses a very old script that hasn’t been adapted yet (and the vendor doesn’t exist anymore). Has PHP 5.3 compatibility been dropped earlier than announced or should I look for some configuration settings (.htaccess, php.ini, Piwik) that have to be changed to reanimate the Piwik installion?

Thanks in advance!


(Matthieu Aubry) #2

Hi there,

piwik should still work fine on PHP 5.3.3 but it’s possible we broke something without noticing. Our automated tests run on PHP 5.3.3 but they don’t test for 100% of the code.


Hi Matt,

thank you very much for your quick reply!

I hope I’ll find some time for debugging this. If I’m able to find some incompatibilities, I’ll let you know.



Maybe I’ve picked the wrong time to be installing PIWIK? The farthest I’ve been able to get through the installer is to the Database Setup. Every step takes many attempts to get past the 502 Bad Gateway screens.The installer can take 3 or 4 tries before it will load the Welcome screen, a few more for the System Check, but can’t get any further, only 502s.

Latest PIWIK version (2.11.1) with PHP (5.3.29). Maybe I have to pressure my service provider to upgrade the PHP?

I’ve looked in FAQS and forum but don’t see this exact problem, seems like something is too slow.

Would the PHP version be the most likely problem?



It could be a PHP version problem. Normally a 502 means that the server or parts of the network are down or too busy, though.

But yes, you should urge your provider to offer current PHP versions. PHP 5.4 was released in March 2012 (!), version 5.5 in June 2013, and 5.6 in August 2014 - support for PHP 5.3 ended in the same month. Which probably even means you should find yourself a new provider as soon as possible… Sticking with PHP 5.3 shows that you provider is either unable to keep up with the technical development or not interested in doing so.

@Matt: My customer agreed to let me make his script compatible with PHP 5.6, which I just finished, so I won’t debug the problems with the old PHP version. Sorry!