Docker Apache Configuration for Matomo: AllowOverride Directive

Hi all,

I’m setting up Matomo in a Docker container and need advice on Apache configuration. A security recommendation suggests using AllowOverride All, but I’m unsure how to implement this in Docker and if it’s necessary.

Questions:

  1. How do I set AllowOverride All in Docker for Matomo?
  2. Is it safe/advisable to do so? Any security implications?
  3. Any Docker-specific considerations for Apache configuration?

Appreciate any insights!

Thanks,