disableBrowserFeatureDetection scheint keine Wirkung zu haben

Hallo zusammen,

ich versuche gerade Matomo im Cookieless-Modus und mit deaktivierten Browser Feature Detection zum Laufen zu bekommen.

Der Tracking Code sieht wie folgt aus:

    var _paq = window._paq = window._paq || [];
    _paq.push(["disableCookies"]);
    _paq.push(['disableBrowserFeatureDetection']);
    _paq.push(['requireConsent']);
    _paq.push(['trackPageView']);
    (function() {
    var u="//<redacted>/";
    _paq.push(['setTrackerUrl', u+'matomo.php']);
    _paq.push(['setSiteId', '1']);
    var d=document, g=d.createElement('script'), s=d.getElementsByTagName('script')[0];
    g.async=true; g.src=u+'matomo.js'; s.parentNode.insertBefore(g,s);
    })();

Im Klaro Consent Manager wird die Einverständnis gesetzt:

_paq.push(['setConsentGiven']);

Das klappt auch soweit alles ganz wunderbar. Allerdings sendet das Matomo Javascript weiterhin die Browser Features. Im POST Request sind die Daten zu sehen.

scheme
	https
host
	<redacted>
filename
	/matomo.php
action_name
	<redacted>
idsite
	1
rec
	1
r
	142679
h
	8
m
	51
s
	26
url
	<redacted>
urlref
	<redacted>
_id
	
_idn
	1
send_image
	0
_refts
	0
pv_id
	3Ge7Su
pf_net
	63
pf_srv
	992
pf_tfr
	1
pf_dm1
	219
uadata
	{}
pdf
	1
qt
	0
realp
	0
wma
	0
fla
	0
java
	0
ag
	0
cookie
	1
res
	1920x1080

Wenn ich der Matomo Administration die Bentuzerprofile aktiviere, sehe ich die Features auch im Bericht.

Was mache ich hier falsch? Verstehe ich hier gerade etwas nicht?

Die einzige Punkt bei dem ich von der Anleitung abweichen musste, war die Stelle an welcher der Tracking-Code eingebunden wurde. Ich habe das Script-Tag vom schließenden Body-Tag eingebunden. Das war in unserem CMS einfacher. Aber das kann ja nicht die Ursache sein oder?

Verwendet wird Matomo 5. (Docker Image Tag: matomo:5-fpm)

Ich wäre für jeden Hinweis dankbar.

Grüße
Alex

Die Funktion zur Deaktivierung der Browser-Feature-Erkennung wird mit Erteilung des Consent deaktiviert. Das bedeutet, solang du keinen Consent mit “setConsentGiven” setzt, wird die Deaktivierung greifen.
Dein Setup geht davon aus, dass du Matomo immer erst nach einem Consent starten möchtest. Dann kannst du auf die “disableBrowserFeatureDetection” verzichten. Diese ist nur dann relevant, wenn du das Tracking auch ohne Consent in einer Basisversion ausführen möchtest.
Dann müsstest anstelle von “disableCookies” und “requireConsent” die Option “requireCookieConsent” einsetzen. Dann wird Matomo ohne Cookies und ohne Browser-Feature-Detection gestartet. Nachdem der Consent erteilt wurde, wird Matomo wieder mit Cookie den Benutzer längerfristig erkenn und auch die Browser-Funktionen messen.
Es gibt leider keine Möglichkeit, auf die Messung der Browser-Funktionen zu verzichten, wenn man einen Consent bestätigt.
Gruß Joachim

Super, vielen Dank für die Info. Da wäre ich jetzt niemals so drauf gekommen.

Das mit dem Consent hatte ich bisher nur gemacht, weil ich zusätzlich noch ein Opt-Out vom Basis-Tracking anbieten will. Da muss ich mir noch was anderes einfallen lassen damit das mit Klaro funktioniert. Aber das bekomme ich schon hin…

Noch mal vielen Dank :grinning: :+1:

Grüße

Den zusätzlichen Opt-Out kannst du über die Matomo-eigene Funktion z.B. in der Datenschutzerklärung umsetzen. Schau mal in den Bereich “Einstellungen → Privatsphäre → Benutzer Opt-Out”.
Wenn du Matomo richtig konfiguriert hast und nur die “richtigen” Daten erfasst, besteht aus meiner Sicht kein Bedarf für den Opt-Out, da keinerlei personenbeziehbaren Daten erfasst geschweige denn gespeichert werden. Rechtlich ist diese Art der Datenerfassung, in den allermeisten Fällen, zulässig. Hier kommt es auf die Entscheidung eures Datenschutzbeauftragten an. Wichtig sind die Einstellungen in Matomo!
Ich wünsche dir weiterhin viel Erfolg und Freude mit Matomo.

Schöne Grüße
Joachim