'Directory does not exist'


#1

Hi guys, I searched and searched the forums and the only thread I could find about this particular error message was all in German.

Itried to set up Piwik today and I’m so close I can feel it but I’m stumped on this last part here.

I’ve setup my website so I have a subdomain ‘stats’. So my site would be stats.example.com. Well I can see that PIWIK is loading when I go to this site, but instead of analytics is says ‘Error occurred’ at the top.

Below this, it states “The directory /var/www/stats.example.com/public_html/tmp/cache/tracker/” does not exist and could not be created. This seems to be possibly a permissions issue with PIWIK trying to record stats. I tried to fix permissionis several times but never got anywhere.

Even if you only provided me with troubleshooting steps to help find out what the issue is I would be very grateful

This is a 14.04 Ubuntu LAMP stack with Apache 2

Thanks!
Connor


(Matthieu Aubry) #2

Hi Connor,

Set permission chmod 777 on your tmp/ folder (or 755 if that’s enough). This should fix it


#3

I’m getting this same error now on an Ubuntu 14.04. Piwik has been running here too … fine since April.

I just got a General error 1030 error 28 from storage engine earlier and tried to clean some space … apparently the wrong thing though.

I replace the /tmp folder (along with empty tmp/assets, tmp/cache, tmp/latest, tmp/tcpdf and tmp/templates_c) and marked tmp as 0777 with www-data:www-data as the owner:group (recursively).

Still shows this last error though: “The directory /var/www/stats.example.com/public_html/tmp/cache/tracker/” does not exist and could not be created."

Any thougts? … seems weird to me.

many thanks in advance

-Brian


(Matthieu Aubry) #4

Hi there

try: chmod 777 /var/www/stats.example.com/public_html/tmp/


#5

Heya,

Yes I tried that with recursive … I.E.:
‘sudo chmod -R 0777 /var/www/stats.example.com/public_html/tmp/’ first.

and then (even though it seemed redundtant to me), tried doing this as well on all the sub folders :S

Because of the course of how this happened … should I be doing any other extra steps? Like renaming the config/config.ini.php, then rerunning the web part of the install process?

Any other insights? Please. :-S

many thx

-B


#6

Thanks, changing permission to 777 in FileZilla worked for me.
Question: should I change it back to 755 afterwards ?


#7

Definitely NOT!

The tmp directory and all its sub-directories and files MUST have 777 permission, regardless of who the owner is.