Custom segments based on campaign name do not work anymore after update from 4.6.2 to 4.9.1

Hi,

I just updated from matomo 4.6.2 to 4.9.1.

I have a custom segment with a filter which compares the beginning of a campaign name to a string, which worked nicely under 4.6.2.

But now in 4.9.1, it is not possible anymore to select any campaign properties to filter segments. And all my old campaign based segments now produce error messages.

Am I missing something or has this crucial feature been removed?

I will revert back to 4.6.2 for now.

Thanks and have a great day

Jens

Can you create and use any kind of other segment?

What is the error (in the UI, in the browser JavaScript Console, in the browser network Console)?
Can you also check the Matomo logs?

I was able to create any segment which did not involve campaign based values.

When I tried to select the campaign based segment, the dashboard showed me messages, that the query may take too long and that I should contact the admin (myself). Upon closer inspection, I saw that now all segment variables have disappeared and are unknown.

Unfortunately, I do not have any logs and I reverted back to 4.6.2 to use campaign name segmentation.

Was this feature removed on purpose or is this some kind of bug?
Or an IUE (incompetent user error)? :slight_smile:

Thanks for your help

Jens

@innocraft, any idea?