curl_exec: Peer certificate cannot be authenticated with known CA certificates


#1

After upgrade to 2.8.0, I can’t archive anymore, message is:


/usr/bin/php -f /var/www/vhosts/example.com/httpdocs/_stats/console core:archive --url=https://example.com/_stats/
INFO CoreConsole[2014-10-16 05:19:31] [ae62b] ---------------------------
INFO CoreConsole[2014-10-16 05:19:31] [ae62b] INIT
INFO CoreConsole[2014-10-16 05:19:31] [ae62b] Piwik is installed at: https://example.com/_stats/index.php
INFO CoreConsole[2014-10-16 05:19:31] [ae62b] Running Piwik 2.8.0 as Super User
ERROR CoreConsole[2014-10-16 05:19:32] [ae62b] The Piwik URL https://example.com/_stats/index.php does not seem to be pointing to a Piwik server. Response was 'Got invalid response from API request: https://example.com/_stats/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was 'curl_exec: Peer certificate cannot be authenticated with known CA certificates. Hostname requested was: example.com''.
ERROR CoreConsole[2014-10-16 05:19:32] [ae62b] The Piwik URL https://example.com/_stats/index.php does not seem to be pointing to a Piwik server. Response was 'Got invalid response from API request: https://example.com/_stats/index.php?module=API&method=API.getDefaultMetricTranslations&format=original&serialize=1&trigger=archivephp. Response was 'curl_exec: Peer certificate cannot be authenticated with known CA certificates. Hostname requested was: example.com''.

Nothing changed in server configuration, just upgraded Piwik to 2.8.0 and before, archiving worked fine. Using a valid SSL Certificate for the website.


(Matthieu Aubry) #2

Maybe your certificate got invalid in meantime or something else is not working?

Cannot help you to debug further that but in case you want to skip the SSL check pass the parameter --accept-invalid-ssl-certificate


#3

I am experiencing this same issue after updating. Is there anything i can provide to help with troubleshooting?