Cronjob Issues on cPanel v86.0.17 and Matomo v3.13.4

I’ve read many posts here with regard to CRON job issues, but I have not had read one yet that fits my situation.

For years, I’ve simply been running it via the Web Browser setting but decided to configure Matomo in order to prevent any degradation of server performance if traffic should start increasing.

I’ve followed the recommendations for setting up CRON within a cPanel hosting account referencing the following example:

/usr/local/bin/php -f /home/yourcpanelsitename/public_html/matomo/console core:archive > /home/example/matomo-archive-output.log

For me this translates to:

/usr/local/bin/php -f /home/MYDOMAIN/public_html/ core:archive > /home/MYDOMAIN/public_html/ 2> /home/MYDOMAIN/public_html/

And if I run this command via the Terminal in cPanel, I receive no errors at all, and thus is what was used to setup the cPanel CRON. When this command was run initially, 2 log files were created in the folder outlined above matomo-archive.log and matomo-error.log and everytime thereafter that that CRON was run, the matomo-archive.log and matomo-error.log “Last Modified” Time/Date is updated but the file size remains at 0 bytes.

I’ve tried changing permissions of these log files from the default 0644, to 0664, 0666, 0766, 0776 and 0777 with no change in results. These files are owned by the user MYDOMAIN:MYDOMAIN so the 0644 permissions should be permission enough.

Interestingly though, on the System Check page within my install, Matomo give the following message:

Uh-oh! Matomo has detected some critical issues with your Matomo setup. These issues should be fixed immediately. See below for more information.

That information is as follows under the Last Successful Archiving Completion heading:

Archiving has not yet run successfully.
Please check that you have setup a crontab calling the core:archive console command, and that you have configured a MAILTO to receive errors by email if archiving fails. You can also try to run the console command to archive your reports manually: /home/MYDOMAIN/public_html/ core:archive.

This message is generated automaticall and yet does not match with what the instructions for cPanel setup.

I’ve tried to get this working in the last few revisions but to no avail. Not sure where to go from here, but it seems I will be using the Browser update feature for now.

Anyone else have a similiar issue, that might be able to point me in the proper direction?

Server Info:
Linux Centos 7
LiteSpeed Web Server