Cron Job stopped after 1.8.4 Upgrade

Hi Chaps

I am running Piwik 1.8.4 on my Windows Server 2003.

I was a happy bunny running 1.8.3. After updating to 1.8.4 my one and only Cron Job (Windows scheduled Task) stopped working. It has been working successfully for over a year.

I ran the DB update from a command line as advised

The Job seems to be running every 2 hours but is it simply starting… Stopping… and it is not processing anything. Sometime ago when I set this up I had a similar problem and I believe it was that some paths had not been declared in an ini file i believe?

Have any files been updated oir overwritten with the update, or is this a known issue?

I have set Piwik to allow auto run on browse and the data has come through, but I need to have the job running as the server has intense periods and requires it

Any help would be welcomed

Thanks in advance

Colin

There shouldn’t be any change since 1.8.3

Maybe this is a permission problem: can you set write permissions to piwik/tmp/ folder recursively for example? is there another error in server error logs?

Hi Matt

Thanks for the quick response.

Feedback: I found what the issue was.

It looks like the 1.8.4 overwrote my Archive file archive.windows.ps1 in the cron folder.

The path to the php.ini was changed.

It had been changed to: $PHP_INI = “C:\Program Files\EasyPHP-5.3.2i\apache\php.ini”

This is not something we would change has we don’t use Apache, we use IIS?

I changed it back to our chosen path c:\windows\php.ini and the job has started running again.

Only 2 people have access to the server and we are sure that we have not made the change to the file. As I said in my post, this job has been successfully running for months

Could the update overwrite the file?

Kind regards

Colin

Yes the update overwrote this file. Please change to using the new cron archiving as explained in: How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo

Hi Matt

Thanks again for a quick response…

Not being the most technical user I am now confused as to how I should be running the Cron Job.

I read the Article that you pointed me to, however, the procedure in Windows must be out of date, or plain old incorrect, because the scheduled task window does not have a “trigger tab”. This is true of Server 2003 and Windows 7

Windows: How to Set up Auto-Archiving Using Windows Scheduler

To open the task scheduler on Windows (XP, 7, 2003/2008 Server) click All Programs, point to Accessories, point to System Tools, and then click Scheduled Tasks.

Click ‘Add Scheduled Task’ and name the task e.g. “Piwik Auto Archiving”. Click on the tab ‘Trigger’ and add a new trigger. Select to create a trigger after a timetable, to be executed daily and every hour. Confirm the settings and switch to the action tab.

In the task properties, in the “Run” input field, you should input the command to run the archiving script, for example
C:\xampp\php\php.exe “D:\www\piwik\misc\cron\archive.php” – url=http://piwik.example.org/

See also this screenshot of the Piwik archiving scheduled task properties window:


Are you saying that I should be pointing at the Archive.php file instead?

Would this have stopped the archive.windows.ps1 path file being overwritten?

Is the Piwik archiving an alternate method?

Regards

Colin

Instructions are for windows XP which I had access to at the time. Please email instructions for newer windows I’ll update the page accordingly. Thanks