Cron-job isn't running anymore (Cron-Job läuft nicht mehr)


#1

Hallo,

sorry - wrong Forum …

habe am Sonntag das Update von 1.3 auf 1.4 gemacht. Seitdem funktioniert der Cron-Job nicht mehr.
Ich habe ihn bei Hosteurope so konfiguriert, dass er alle 6 Stunden lief und habe nach Abschluss jedes mal eine entsprechende Mail bekommen:


Starting Piwik reports archiving...


Archiving period = day for idsite = 1...
<?xml version="1.0" encoding="utf-8" ?>
<results>
	<result date="2011-03-11">1759</result>
	<result date="2011-03-12">1352</result>
	<result date="2011-03-13">1849</result>
	<result date="2011-03-14">2007</result>
	<result date="2011-03-15">1941</result>
	<result date="2011-03-16">2006</result>
.
.
.
Reports archiving finished.
---------------------------
Starting Scheduled tasks...

No data available
Finished Scheduled tasks.


Jetzt bekomme ich immer nur:


Starting Piwik reports archiving...


Mehr nicht. Woran kann das liegen? Bin für jeden Tipp dankbar.

Jan


#2

The user excecuting the archive.sh is missing write rights for “tmp” folder.

The solution is to add write rights to the /path/to/piwik/tmp folder

or simply execute:

chmod -R a+w /path/to/piwik/tmp


#3

In my case the directory already has 755. But there is a .htacess with deny from all in it… I disabled it, lets see if it works now. Any other subdir that needs 755 or the .htaccess removed???


#4

If you call archive.sh via shell the .htaccess is not in effect.

755 means: no write access for group and all. Are you sure the user calling the archive.sh is the owner of tmp?

Try as stated above and it should work: chmod -R a+w /path/to/piwik/tmp


#5

I changed cmod to 777 now… Lets see what happens. I guess many of the problems appear because the documentation always assumes that people have their own webserver.


#6

Hi,

I’ve tried different settings and users now (755, 777, ftp, nobody) with no effect. I gave to my webhoster, hosteurope. Fortunately they have a great and quick support. During a quick chat with them, they didn’t see any any obvious problems so they are diving in deeper now.
If there’s any news, I’ll post them.

Cheers so far,
Jan


#7

After talking with my webhoster it seems clear that a .sh script cannot be executed from a webspace. I would need a webserver for this. Beside the question how it worked so far I actually see no possibility to continue using piwik if there is no php script doing the archiving.


(Thomas Seifert) #8

Get a hoster who allows you real cronjobs!

The shell script is there to circumvent some of the limitations which are occuring when run through the webserver. If you want to run it through the webserver, then you loose every gain of that. Just use browser based archiving then - its a php script! :wink: