Cron Error - Got invalid response from API request for GEOIPAutoUpdater


(Neil Gee) #1

After upgrading to 2.10.0 I am getting an error from Cron job about plugin GEOIPAutoUpdater…


ERROR CoreConsole[2015-01-22 22:09:00] Got invalid response from API request: http://secure.coolestguidesontheplanet.com/piwik/index.php?module=API&method=CoreAdminHome.runScheduledTasks&format=csv&convertToUnicode=0&token_auth=161445116a591bf6d48fe1ae54552a32&trigger=archivephp. Response was 'task,output Piwik\Plugins\ExamplePlugin\Tasks.myTask,Time elapsed: 0.000s Piwik\Plugins\UserCountry\GeoIPAutoUpdater.update,ERROR: Encountered unsupported archive type 'dat.gz.'.'
ERROR CoreConsole[2015-01-22 22:09:00] 1 total errors during this script execution, please investigate and try and fix these errors.
ERROR CoreConsole[2015-01-22 22:09:00] 1 total errors during this script execution, please investigate and try and fix these errors.



 [Exception]                                                                                    
 1 total errors during this script execution, please investigate and try and fix these errors.  



core:archive [--url="..."] [--force-all-websites] [--force-all-periods[="..."]] [--force-timeout-for-periods[="..."]] [--skip-idsites[="..."]] [--force-idsites[="..."]] [--force-periods[="..."]] [--force-date-last-n="..."] [--force-date-range[="..."]] [--concurrent-requests-per-website[="..."]] [--disable-scheduled-tasks] [--accept-invalid-ssl-certificate] [--xhprof]

Any fixes?


(Matthieu Napoli) #2

ERROR: Encountered unsupported archive type ‘dat.gz.’

Same answer than in the other post you made: ‘dat.gz.’ there’s an extra “.” at the end, is that maybe the cause of the error?