Cron Archive Doesn't Work & Plugins Timeout

I just completed a format and reinstall of Ubuntu Server 16.04.01 LTS and Piwik is having some very strange problems.

When i run the archive cron, for all my sites i get the errors:

Error: Empty or invalid response ‘’ for website id

Also, whenever i go to the plugins or marketplace pages the page just times out (this has happened even in my old setup).

Nginx error log shows:

2016/08/17 01:48:25 [error] 24156#24156: *95 upstream timed out (110: Connection timed out) while reading response header from upstream, client: x.x.x.x, server:, request: “GET /index.php?module=CorePluginsAdmin&action=plugins&idSite=1&period=day&date=yesterday&activated= HTTP/1.1”, upstream: “fastcgi://unix:/var/run/php/php7.0-fpm-piwik.sock”, host: “”, referrer: “

Any idea how to fix these things? I’m using Nginx and Php 7.0.9.

Hello, are you using Piwik 2.16.2? if not please update. What is the full output of core:archive script?

2.16.2 is installed, here’s full output:

Also, merci :wink:

P.S. I found out why plugins/marketplace times out for me. I have allow_url_include set to off in php.ini. You should add this to system file check page and let users know why they need it.

I fixed it. I had some classes disabled for CLI version of PHP. Disabling them fixed the problem.

Hi . What classes did you disable ?