Create Segment Page URL (Huge Data)


#1

We are running 2.0.2 The database is approx 10gb. When I go to create a new segment using the page url filter, it takes an incredibly long time to pre-fill the url list, effectively locking the table, resulting in locked transactions for the live data that is coming in. We’re getting on average 5 hit per second during peak times. We dont want to go over 500 max connections on our database, which we hit every time i try to add a new segment. Is there a way to not have the segment editor query the table for the prefilled url list so i can just specify it? Or is there a better option? Many thanks.


(Matthieu Aubry) #2

Thanks for the report… please create a bug ticket at: http://dev.piwik.org/
maybe we can find solution or make request faster.


#3

What are the memory setting you have on the php.ini? if around only 512 megs or less can you increase to 1 gig or more to see if it helps things?


#4

Problem is not memory related I presume. If it’s like my case, the problem is Ajax in the Segment Editor when there’s too many variables.

See my ticket about such problem : Segment Editor: request should timeout when it takes too long to generate auto suggested values · Issue #4253 · matomo-org/matomo · GitHub

BTW, Skerbater created his ticket: Create Segment w/ Page URL filter (Huge Database) · Issue #4509 · matomo-org/matomo · GitHub

Dali


#5

Right… the issue i think stems from sheer amount of data we have in database queried using Segment Editor (49 unique sites and 3,939,294 rows in piwik_log_action to give you an idea) We are a large institution.