Crash after update attempt


#1

I naively clicked on the link in the friendly update reminder email and now I’m left with this trash.


There is an error. Please report the message (Piwik 2.7.0) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Use of undefined constant QQ9iU7nr7J - assumed 'QQ9iU7nr7J' in /var/www/virtual/vrech/html/piwik/plugins/UserSettings/Reports/Modifier.php on line 2 

Backtrace -->

#0 Piwik\Error::errorHandler(...) called at [/var/www/virtual/vrech/html/piwik/plugins/UserSettings/Reports/Modifier.php:2]
#1 require_once(...) called at [/var/www/virtual/vrech/html/piwik/core/Plugin.php:449]
#2 Piwik\Plugin->doFindMultipleComponents(...) called at [/var/www/virtual/vrech/html/piwik/core/Plugin.php:364]
#3 Piwik\Plugin->findMultipleComponents(...) called at [/var/www/virtual/vrech/html/piwik/core/Plugin/Manager.php:333]
#4 Piwik\Plugin\Manager->findMultipleComponents(...) called at [/var/www/virtual/vrech/html/piwik/core/Plugin/Report.php:662]
#5 Piwik\Plugin\Report::getAllReports(...) called at [/var/www/virtual/vrech/html/piwik/core/Menu/MenuReporting.php:129]
#6 Piwik\Menu\MenuReporting->getMenu(...) called at [/var/www/virtual/vrech/html/piwik/plugins/CoreHome/Controller.php:135]
#7 Piwik\Plugins\CoreHome\Controller->getDefaultIndexView(...) called at [/var/www/virtual/vrech/html/piwik/plugins/CoreHome/Controller.php:168]
#8 Piwik\Plugins\CoreHome\Controller->index(...) called at [:]
#9 call_user_func_array(...) called at [/var/www/virtual/vrech/html/piwik/core/FrontController.php:577]
#10 Piwik\FrontController->doDispatch(...) called at [/var/www/virtual/vrech/html/piwik/core/FrontController.php:86]
#11 Piwik\FrontController->dispatch(...) called at [/var/www/virtual/vrech/html/piwik/core/dispatch.php:34]
#12 require_once(...) called at [/var/www/virtual/vrech/html/piwik/index.php:46]


(Matthieu Napoli) #2

The piwik/plugins/UserSettings/Reports/Modifier.php file doesn’t seem to exist in the official distribution. And the error message is weird…

Could you maybe download and re-upload Piwik’s files manually:

  • download Piwik 2.7.0 here: https://builds.piwik.org/
  • backup your configuration file (config/config.ini.php)
  • unzip Piwik and upload the files to override the existing ones
  • restore the configuration if it was erased

The procedure is explained in more details here: Update Piwik - Analytics Platform - Matomo

Before doing that, could you also post the content of piwik/plugins/UserSettings/Reports/Modifier.php here just so that we can understand?


(Matthieu Aubry) #3

Maybe you’ve been hacked ? what other softwares do you run on your server besides pIwik?


#4

Hi,
thanks for the answer.

There is no Reports folder in UserSettings

[update]
sorry, I didn’t have time for more tests. I just grabbed the latest.tar.gz, copied the config.ini.php over and it’s running again.


(Matthieu Aubry) #5

Well your server is likely been hacked, so if I weer you I would take some time to investigate :slight_smile:


#6

Isn’t that judging a little too fast? What makes you say that? Because the Reports folder is missing? Now 2.9 is running fine and that folder is still not there.


(Matthieu Aubry) #7

Ok it could be false interpretation indeed, but often these reports from files that we don’t use at Piwik, mean that some malware tries to load the file. but here could be something different, cheers!