Count(): Parameter must be an array or an object that implements Countable


(Editions Brandon) #1

When I loged on to piwik, I got the following warning.

WARNING: /srv/http/betc/piwik/plugins/Live/Controller.php(169): Warning - count(): Parameter must be an array or an object that implements Countable - Piwik 3.2.1 - Please report this message in the Piwik forums: https://forum.piwik.org (please do a search first as it might have been reported already)


(Lukas Winkler) #2

Hi,

I assume you are using PHP 7.2 as this has changed from PHP 7.1.
I think Piwik isn’t fully PHP 7.2 compatible but you can help us make it.

Can you open a new Github Issue and provide a bit more details about your system and how to reproduce the issue there.


(Editions Brandon) #3

Yes, I am using php 7.2.0 on archlinux 32bit. Unfortunately I won’t be able to describe the steps to reproduce the issue,
since I got error message only once when I updated piwik version. So, I am afraid I won’t be of much help.


(Editions Brandon) #4

Hello, this is just to tell you that I got this message again today at the login. I hadn’t seen this for months now…


(Fabian Dellwing) #5

Matomo still does not officially support PHP7.2, this problem still should be fixxed. But sadly that is impossible without a way to reproduce ist.