Cookie Opt-In, Opt-Out Checkbox Dysfunctional


(Roddy A. Stegemann) #1

Until I upgraded to Matomo 3.4 the opt-in / opt-out checkbox for personal cookie tracking worked fine. Now when the box is checked or unchecked the screen turns blank before reloading the page and the following error messages fills the installed <iframe>

— Begin Error Message —
Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at webmaster@nudge.thegenaproject.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

Additionally, a 500 Internal Server Error error was encountered while trying to use an ErrorDocument to handle the request.
— End Error Message —

Not only this but my Matomo email address is transformed from admin@nudge.online to webmaster@nudge.thegenaproject.com. This latter address does not exist.

Please advise.

Note: My host server uses PHP 6.7, not 7.0.

Roddy


(Fabian Dellwing) #2

The adress of the server admin is set via your webservers vhost, so this change is pointing towards an missconfiguration of your server.


(Roddy A. Stegemann) #3

Thank you, Fabian, for responding, but it is curious that you would address the problem of the invalid email address, and Lunarpages (my webhost) would respond to the problem of the dysfunctional checkbox mechanism. Based on what you have told me and what I have observed, the responses should have been the opposite.

Here is how Lunarpages responded to the aforementioned error message.

"I added the following lines :

memory_limit = 256M
max_execution_time = 300
max_input_time = 300
upload_max_filesize = 100M
upload_tmp_dir = 128M
post_max_size = 128M

MAGICK_THREAD_LIMIT = 1

to the .user.ini file in your public_html folder, …"

In any case the internal server error persists and the invalid email address has not been replaced with anything resembling the email address that I provided Matomo – namely, admin@nudge.online.

At your suggestion I will continue to encourage Lunarpages to address the problem of the invalid email. Please, however, I would greatly appreciate a response from Matomo, you, or others regarding the internal server error. Usually blank pages are brought about by improper PHP code.

So, that you might replicate the error yourself, please follow the set of instructions below and replicate the problem for yourself:

  1. Open to the Grammar Captive mainpage at Grammar Captive Overview

  2. Find in the navigation bar the subheading Other and click on the item entitled Legal/Privacy

  3. Find the heading Data Collection and Analysis and scroll down until you see the checkbox.

  4. Check or uncheck the box and observe the behavior.

  5. Refresh the page.

  6. Repeat items 4) and 5).

What do you believe to be the likely source of the internal server error.

Roddy


(Lukas Winkler) #4

Hi,

Internal Server Error is a message the webserver sends when it doesn’t get anything useful from PHP.
So the message (and the E-Mail) doesn’t come from Matomo, but the webserver.

Why PHP doesn’t work (probably because an exception happens), you can find out in the PHP error log.


(Roddy A. Stegemann) #5

I have sent an email to my host server requesting the whereabouts of the PHP error log. In the meantime this is what they sent me regarding the internal server error:

“Cannot allocate memory: [client 84.117.78.206:50919] couldn’t create child process: /usr/sbin/suphp for /home/thege0/public_html/nudge.online/_utilities/php/matomo/index.php, referer: the_link_in_question_that_the _forum_is_currently_blocking_as_spam”

Is there something about the Matomo process that could be causing an inordinate demand for memory?

Roddy


(Roddy A. Stegemann) #6

BACKGROUND
I have uploaded two files that capture 24-hours worth of server faults. A fault occurs when a user’s site exceeds an allotted CPU, memory, I/O, or other connectivity related usage limit. When such a limit is exceeded a site’s access to my host’s shared SSL server is temporarily shut down.

Such a shut down could explain the blank page and internal service error that appear when a user checks or un-checks the opt-in/opt-out toggle-box for receiving or not receiving a tracking cookie when he downloads my website.

The FILES
I have divided the data into two files (lines 1-40 and lines 41-73). I have also hidden columns that exhibit no fault activity.

Each item on the left under the From and To columns represents a one-hour interval during which the indicated processes to the right took place.

During each one-hour interval one or more snapshots were taken of instances of excess usage. Each snapshot records a five-minute interval of my site’s server activity. These intervals can be easily recognized by the relative proximity of the values of the ID numbers of the associated processes (PIDs)

The number of httpd -k start processes appears to be closely related to the number of other processes that occur during the same five-minute interval. In other words, each time the matomo.index page is accessed my webhost provider’s Apache server is started anew.

DISCUSSION

There appear to be several ways that I can resolve the problem.

  1. Limit the total number of calls to the Matomo application within a five-minute period.
  2. Limit the number of calls to the Matomo application from the same user during a five-minute period.
  3. Eliminate the need to restart the Apache server each time that a request to the Matomo application is made.

QUESTION: Does any of the above make sense to you? Have you other causes or remedies in mind? If my own suggested causes and remedies appear reasonable, can you suggest ways that I might implement my suggested remedies.

LINES 1-40

!

LINES 41-73
snaphosts_lines41-73|690x369