Continual MySQL archiving problems ::o


#1

Firstly I’d like to thank the developer and all contributors to the Piwik app - its a great piece of work. :slight_smile:

However, as a user I’m getting increasingly frustrated with it as each day passes.
Simply because of continual archiving problems.

I’m tracking 25 sites at the moment and continually receive SQL connection/time out issues;

SQLSTATE[HY000]: General error: 2006 MySQL server has gone away

During archiving.

In fact its only processing 4 of the 25 sites now so no data is updating for the other sites.

I’m on a VPS with sufficient resources and run a number of apps. without any SQL problems.

My webhost Hostgator has tried various SQL tuning settings (as have I) and we just can’t get it to stabilise. In fact any tuning we apply makes the problem worse.

As a result I’m now forced to run OWA alongside Piwik and I’m not getting any problems with OWA.

I’ve seen many threads about this problem so I’m sure I’m not the only one suffering here and I’m wondering (as a last ditch attempt) if there is anything that I can do as I’m getting to a point where I’m going to have to drop Piwik (against my preference).

I also notice (as a side issue) many time outs with the Piwik site itself when trying to access docs or the forum and content doesn’t get served. Again accessing the OWA site and forum works just fine.

Once again I’m a big fan of Piwik for the few weeks that I’ve been using it and wan’t to keep using it if I can, however if I can’t resolve this issue I will have to move away.:frowning:


(Matthieu Aubry) #2

Our site is down because of DDos attacks which are getting annoying…

Regarding the mysql error, this is a common one, see this page for the 2 tips that usually fix the issue: How to fix “MySQL server has gone away” (error 2006) » Autarchy of the Private Cave

How many visits per day do you track?

Mysql gone away is definitely a mysql problem not piwik so I would really look into changing mysql settings


#3

Thanks Matt.
Sorry to hear that piwik has become a target.
I’m tracking around 2K+ visits per day across those sites.
I’ve tried the settings in that thread (and others) - will give it another go with just those two and see what happens and check that I’ve set it correctly.
Nic.


#4

Well I’ve spotted the first idiotic mistake. These settings weren’t applied correctly!!
Now they are, so I’ll test it and report back.
Thanks again Matt.


#5

Yep, that sorted it Matt. (:P)
Thanks and apologies for not checking (it was applied correctly) before.