Class 'Piwik\Log' not found in .... [php 5.3.2]


(Matthieu Aubry) #1

With PHP 5.3.2 only (already 6 years old, time flies), there is a bug in Piwik 2.0 that says:


Class 'Piwik\Log' not found in piwik/core/DataTable/Filter.php 57

Sorry about this bug, it’s a bug in PHP

  1. can you ask webhost to update php to latest version (5.3, 5.4 or 5.5 work)

  2. sometimes it’s possible to update yourself to latest php via the admin interface of web hosting panel

  3. otherwise you can revert to Piwik 1.12 downloadable from http://builds.piwik.org/piwik-1.12.zip

Steps to revert to Piwik 1.12
A) backup config/config.ini.php
B ) delete all piwik/* files
C) uncompress piwik 1.12 files
D) copy your config.ini.php to piwik/config/
E) visit Piwik, it should run on 1.12

Sorry about the trouble, we tried hard to fix all bugs even with some old php versions but we missed this particular version.

We hope you like the new release & let us know your feedback or share the word…


#2

This is the PHP Version that is shipped with Ubuntu 12.04 LTS. So something that not so odd that it was not tested. This is really a point where I’m thinking of not using Piwik anymore.


(Matthieu Aubry) #3

Umh that’s a good point I used to be on there (using 12.04 myself) but have upgraded to 5.5 2 months ago… we must have put this code since. We will look for a fix but it may not be easy since it’s a bug in php itself… I get your pain and hope you will not stop Piwik for this (tu)


#4

I would also update to php 5.5 but I’ve Plesk on my V-Server and Plesk just works with 5.3 :frowning:
But since the Downgrade of Piwik worked it is not that bad that I thought at the start.


(Peterbo) #5

Plesk can work with other PHP Versions flawlessly since recent versions. I have Plesk 11.5 installed with PHP 5.5.7 and percona DB. Not a problem at all.


#6

well, how did you install PHP? I wanted to install it through a third-party Ubuntu PHP repository. But this would remove all Plesk Packages from my system and not all of the PHP modules I use are supported by the third-party source. So this is really a total mess. I would have to compile the complete PHP with all my modules and would have to to this again for every update? From my point it’s easier to stay on Piwik 1.12 activate Google Analytics and wait. Maybe I’ll update my server… or Piwik will find a work around or I’ll turn back to Google…


(vipsoft) #7

The good news is that I saw the latest commits in git have fixed the underlying error that triggered the error handler. Expect a release soon.

BTW for the sake of accuracy, Ubuntu 12.04 LTS’s php5 package is 5.3.10.

https://launchpad.net/ubuntu/precise/+source/php5

On the bright side, when Canonical freezes their packages next month, we expect php 5.5.x to be in the next LTS.


#8

Sorry, it’s 10.04 LTS :frowning:


#9

For people with 10.04 LTS

I applied manually on a 10.04 LTS lucid with PHP 5.3.2-1ubuntu4.22 with Suhosin-Patch (cli) (built: Dec 12 2013 04:16:22)

The following changes manually


and

Now Piwik 2.0 is running on our server like before.


(Matthieu Aubry) #10

See ticket Class 'Piwik\Log' not found in .... [php 5.3.2] · Issue #4398 · matomo-org/matomo · GitHub

It is now fixed in 2.0.1!