CentOS6: Suppress PHP warning


#1

Upgraded from 2.3.0 to 2.8.3 on CentOS 6.
Since then, I receive the PHP warning, as CentOS 6 comes with PHP 5.3.3.
Upstream vendor backports security patches to this version regularly but does not update the major version in this OS.

Is it possible to suppress the PHP warning?

Thanks!


(Matthieu Aubry) #2

Which warning?


#3

Warning
Piwik will stop supporting this PHP version in May 2015. Upgrade your PHP version before it’s too late! The PHP version 5.3 you are using has reached its End of Life (EOL). You are strongly urged to upgrade to a current version, as using this version may expose you to security vulnerabilities and bugs that have been fixed in more recent versions of PHP.

That might be true for other distros, but not for CentOS / RedHat Enterprise Linux, were RedHat backports security fixes. Currently, CentOS 6 is using PHP 5.3.3 and has an EOL of November 30th, 2020:


(Matthieu Aubry) #4

the warning is because PHP is EOL but also because we plan to stop support 5.3.x in May. So in May you wont be able to update Piwik to latest version if you use 5.3.x - that’s why the warning is important and we recommend all piwik users to use 5.4+ so they can keep using latest & greatest Piwik (including critical security fixes in piwik)