Centos 7.5 with Nginx and GEOIP2 won't update dashboard


(Mike van Eckendonk) #1

Hi,

I guess that I have setup all things correctly but maybe I’m missing something that I can’t find. Nginx has all modules compiled like

--with-http_geoip_module
--with-stream_geoip_module
--with-stream_realip_module

all modules are loaded in a nginx config file

# GeoIP2 Lite databases
  #  geoip2 /usr/share/GeoIP/GeoLite2-Country.mmdb {
  #    auto_reload 5m;
  #    $geoip2_metadata_country_build metadata build_epoch;
  #    $geoip2_data_country_code country iso_code;
  #    $geoip2_data_country_name country names en;
  #  }

  geoip2 /usr/share/GeoIP/GeoLite2-City.mmdb {
    auto_reload 5m;
    $geoip2_metadata_city_build metadata build_epoch;
    $geoip2_data_city_name city names en;
    $geoip2_data_city_geonameid city geoname_id;
    $geoip2_data_continent_code continent code;
    $geoip2_data_continent_geonameid continent geoname_id;
    $geoip2_data_continent_name continent names en;
    $geoip2_data_country_geonameid country geoname_id;
    $geoip2_data_country_code country iso_code;
    $geoip2_data_country_name country names en;
    $geoip2_data_country_is_eu country is_in_european_union;
    $geoip2_data_location_accuracyradius location accuracy_radius;
    $geoip2_data_location_latitude location latitude;
    $geoip2_data_location_longitude location longitude;
    $geoip2_data_location_metrocode location metro_code;
    $geoip2_data_location_timezone location time_zone;
    $geoip2_data_postal_code postal code;
    $geoip2_data_rcountry_geonameid registered_country geoname_id;
    $geoip2_data_rcountry_iso registered_country iso_code;
    $geoip2_data_rcountry_name registered_country names en;
    $geoip2_data_rcountry_is_eu registered_country is_in_european_union;
    $geoip2_data_region_geonameid subdivisions 0 geoname_id;
    $geoip2_data_region_iso subdivisions 0 iso_code;
    $geoip2_data_region_name subdivisions 0 names en;
  }

  geoip2 /usr/share/GeoIP/GeoLite2-ASN.mmdb {
    auto_reload 5m;
    $geoip2_data_autonomous_system_number autonomous_system_number;
    $geoip2_data_autonomous_system_organization autonomous_system_organization;
}

Everything seem to work. See images below, but for some reason the dashboard still look at the used language browser.


But I got still an error when checking the config.

What could be wrong?

The only thing I did not do, becuase it looks like that everything is ok, is to install the maxminddb extension


(Mike van Eckendonk) #2

Just to give a BUMP to it became I changed the location of this post.

As I noticed you also did a PUSH request on Github for the user @eva2000, so I guess that I have to wait for a solution. Currently, testing the latest BETA to see if it works and to get the patch faster.


(Fabian Dellwing) #3

Did you try this? I know it’s only a workaround, but might solve your problem until PR is merged.


(Mike van Eckendonk) #4

Read about it but I don’t know where to set it to any value. Just started some weeks ago using matamo.

But I’m getting also a 400 error on the tracking image.

Response Version
HTTP/2.0
Response Headers
x-powered-by	centminmod
cache-control	no-store
**status 400**
date Tue, 23 Apr 2019 16:26:47 GMT
content-type	image/gif
x-xss-protection 1; mode=block
x-content-type-options	nosniff
server nginx centminmod
Request Version HTTP/2.0
Request Headers user-agent	 
Mozilla/5.0 (X11; Linux x86_64) AppleWebKit/537.36 (KHTML, like Gecko) Chrome/62.0.3202.94 Safari/537.36

accept image/webp,image/apng,image/*,*/*;q=0.8
:method	GET
accept-language	en-US,en;q=0.9
accept-encoding	gzip, deflate, br
:authority	domain.com
:scheme	https
:path	/analytics/matomo.php?action_name=