CDN Cloudflare


#1

bonjour
Voila 2 semaine que j’utilse CDN Cloudflare . Mes stats dans piwik sont modifiées Tous mes visiteurs proviennet que d’un seul pays : USA. Cependant dans les logs visiteurs je vois bien les url de pays différents.
J’utilise par en local ( WAMP) une copie de mon site eh bien même mes connexions sont prises en compte, C’est curieux , non? Avant CDN Cloudflare je n’ai jamais ce probléme
Par ailleurs, impossible d’afficher :
le graphique des derniéres visites, Carte en temps-réel, Carte des visiteurs,

quelqu’un est déjà utilisé Cloudflare avec piwik?
Nick


#2

Hello,

Il faut modifier la configuration

http://piwik.org/faq/how-to-install/faq_98/

Pablo


#3

merci pour cette info , je vais demander à mon hébergeur d’installer ce module Je verrai bien si c’est possible…


#4

Tu peux modifier ton fichier global.ini.php, cela devrait fonctionner.


;proxy_client_headers[] = HTTP_CF_CONNECTING_IP

Supprime le ;

PS je n’ai jamais essayé, mais c’est dans la doc : How do I configure Piwik when the server is installed behind a proxy? - Analytics Platform - Matomo , mon deuxième lien du post précédent et des utilisateurs en parle ici :
301 Moved Permanently
et
301 Moved Permanently

Il faut aussi prendre un compte si ton site est en HTTPS ou pas
Si c’est le cas tu devra modifier aussi config.ini

Tout est là : How do I configure Piwik when the server is installed behind a proxy? - Analytics Platform - Matomo

Pablo


#5

malheureusement je n’est pas access à global.ini.php
j’ai simplement access à php.ini
@+ Nick


#6

C’est un fichier qui trouve dans piwik et qui est indépendant de php.ini


#7

j’ai trouvé le php.ini , et j’ai oté le “;” qui était devant la ligne et apparemment ca marche. Par contre depuis l’utilisation (il me semble) de Cloudflare je ne peux plus visualiser :
-Graphique des dernières visites
-Carte en temps-réel
-Carte des visiteurs
-Visites par fuseau horaire du serveur

et lorsque le clic sur “visiteur” dans le menu, je n’ai pas de graphique, d’ailleurs sur les autres menus aussi, j’ai bien les textes mais pas de graphique
Les zones restent blanches
bizarre…


#8

bonjour
la maj à réglé l’affichage des infos que je mentionnais dans mon post précédent.
je reviens à Cloudflare concernant la solution de pablofr plus haut. j’ai bien activer
proxy_client_headers[] = HTTP_CF_CONNECTING_IP dans le global.ini.php de piwik , cependant en allant dans :
Diagnostic > Vérification du système
j’ai un message qui apparait :
" Le contrôle d’intégrité a échoué et a rapporté des erreurs. Cela est probablement dû à un envoi de fichier partiel ou en échec des fichiers de Piwik. Vous devriez envoyer de nouveau les fichiers de Piwik et rafraîchir cette page jusqu’à ce qu’elle n’affiche plus aucune erreur.
Différence de taille de fichier : /home/xxxxxxxx/piwik/config/global.ini.php (longueur attendue: 37774, rencontrée : 37773)

C’est important ?
Merci


(Matthieu Aubry) #9

Bonjour

il vous faut mettre cette information dans le fichier config/config.ini.php (dans une section [General]) et non dans global.ini.php


#10

ok je l’ai mis dans le config/config.ini.php
Mais dans le post pablofr plus haut, il suggérait de l’activer dans le config/global.ini.php ainsique dans la doc (???)…
je te fait confiance car c’est un domaine dans lequel je n’y comprends pas trop

Merci