Can't upgrade Piwik 1.12 to any newer version


#1

Hey guys,

I’m wasted some months ago and today again a lot of hours by trying to update my piwik 1.12 to any newer version.

The error appears in the local copy as well at the server. All requirements are fine and before the failed update everthing is running. It does not matter If im using the automatically update or 3-step-update.

By the One-Click-Update I get a blank screen after the update. Then I can’t login anymore to the userinterface because it requires a superuser. The database shows up, that there is no superuser entry in the table. By clicking “Forget the password” I get everytime the call for an update. Afterwards I get again the blank screen… It’s a vicious circle.

By using the Three-Step-Update I get after the successfull sql changes that massage:

Fatal error: Class ‘Piwik_Plugin’ not found in C:{xxx}\piwik\plugins\DoNotTrack\DoNotTrack.php on line 20
Fatal error: Class ‘Piwik_Plugin’ not found in C:{xxx}\piwik\plugins\ExampleUI\ExampleUI.php on line 27

Have anyone any idea?

It’s really frustrating. Now I’m moving the server and what’s why I would like to get an update.

I tried several Piwik 2.X version and even a fresh installation of Piwik 1.12 with the old database did not helped :frowning:
Piwik 1.2, Piwik 1.2.1, Piwik 1.8 failed to update successfull…

Is there any possibility to make a fresh Piwik 2.X installation and import the userfiles out of piwik 1.1.2?


#2

Okay, I solved it. First install Piwik 2.0 then let it update…