Cant login into 0.5.5


(KalleKelle) #1

i just did a update and even after two hours doing anything possible i can login.
i even installed a complete new version with a new database, no way.

after typing in user and passwort, the screen just refreshes and i see the same blank login screen as before.
after complete reinstall with new database, i did copy and user and pass the the config file, no chance.

there must be something really wrong!


(Matthieu Aubry) #2

can you clear your cookies? try with different browser or computer? try logging as super user, and/or another user?


(status4) #3

I got the same problem style_emoticons/<#EMO_DIR#>/sad.gif

I have cleared the cookies, reinstalled 2-3 times, nothing is working after the update.
There also isn´t a error message or anything else. I try to login an nothing happens.

The system check fails too, but I have definitely uploaded alle the files completely.
For misc/generateDoc.bat and some files in libs/open-flash-chart. But I think this
could not be the reason for the login problem or?

Do you have any advice on this please?

Thanks a lot.


(Matthieu Aubry) #4

please send your piwik url, login, pwd and server details (SSH or FTP) at matt attt piwik.org


(KalleKelle) #5

its definatly not a cookie problem i tried with 3 browser.


(vipsoft) #6

Can you add some debug statements to core/Piwik.php and PM back the results?

(Note: the line numbers are just for reference)

1943    static public function verifyNonce($id, $nonce)
1944        {
1945            $ns = new Zend_Session_Namespace($id);
1946            $snonce = $ns->nonce;
1947    
1948            // validate token
1949            if(empty($nonce) || $snonce !== $nonce)
1950            {

                    var_dump($nonce):
                    var_dump($snonce):

1951                return false;
1952            }
1953    
1954            // validate referer
1955            $referer = Piwik_Url::getReferer();
1956            if(!empty($referer) && (Piwik_Url::getLocalReferer() === false))
1957            {

                    var_dump($referer);
                    var_dump(Piwik_Url::getLocalReferer());

1958                return false;
1959            }
1960    
1961            return true;       
1962        }

(KalleKelle) #7

i guees i have to take out the line numbers?

i got back this:

Parse error: syntax error, unexpected T_PUBLIC, expecting T_VARIABLE in /www/htdocs/xyz/piwik/core/Piwik.php on line 22

Fatal error: Class ‘Piwik’ not found in /www/htdocs/xyz/piwik/core/FrontController.php on line 164


(vipsoft) #8

My changes are nowhere near line 22.

Try using the attach copy of Piwik.php. I’ve included the aforementioned edits.


(vipsoft) #9

And this is the original for you to restore after you’ve helped with debugging the cause.


(KalleKelle) #10

ah ok, thanx!

here is the snwere: string(32) “220f25f24b3cb11cf4202afd295abfb6” string(32) “9dfb63150ae6680c677557059aa9e34d”


(vipsoft) #11

Try disabling your browser extensions/addons. YSlow and Firebug have been observed to cause a double fetch, and thus, resetting the nonce. AFAIK there’s no way to differentiate between a background fetch by the extension vs a refresh by the user.


(mo2402) #12

I have the same problem with Firefox 3.6, Google Chrome 4, Opera 10 and Internet Explorer 8. It should be no Plugin problem.


(chx) #13

Problem occurs also on Firefox 3.5.8 and 3.6.2 without any extension, Opera 10.0 and IE 6.0. So is is definitivly not related to any firefox extension.

In relation to the 0.5.4 installation I activated the Anonyme-IP-Plugn. Maybe this caused any trouble?


(Matthieu Aubry) #14

Anthon, is there a change that the bug fix in: http://dev.piwik.org/trac/ticket/1236 would also fix these issues?

If they don’t use extensions like YSlow or firebug, but have a pre-fetch proxy or something similar?

Guys, if you know how to apply patches, please try the fix in the ticket above and let us know.


(vipsoft) #15

It should handle the case where there is a browser pre-fetch. Whether or not it’ll work with a proxy will depend on how transparent the proxy is. A good proxy would cache the content, and pass it up to the browser intact with the headers.


(vipsoft) #16

If it’s affecting multiple browsers then the problem isn’t Piwik. It’s probably something like ZoneAlarm or AVG anti-virus doing a link check. The fix is to whitelist your Piwik server or disable the link checker.


(chx) #17

Interesting thesis… Most people would guess the exact opposite: If the problem persists from different browsers, it cannot be the browser.

I also checked from different networks including using lynx directly on the server itself. Same problem.


(vipsoft) #18

chx: I didn’t say it was the browser. I was referring to third-party apps.

If you want to help debug, use the modified version of Piwik.php and post your results.

If you’re technical enough, you can apply the changes from http://dev.piwik.org/trac/changeset/1981 to see if this fixes the problem for you.


(chx) #19

I applied the patch - no change.

Even if I connect via telnet and send a login request manually, I am redirected to the default login page - without and error message or warning.


(vipsoft) #20

Sorry, I can’t help you with telnet or Drupal’s multi-site hosting. If this isn’t the standard Piwik login form, you’ll have to ask the Drupal integration developers (or have them contact us).