Can't install (can't go beyond Super User setup)


#1

Hi, I have been trying to install piwik 2.14.0, but I can’t go past the step 3, Super User setup. When I choose super user login and password, and click
on “next” button, I get back to the “welcome” screen.

In php error log (I found nothing in apache error log) there are following lines (I changed the name of the path)

[05-Aug-2015 03:45:07] PHP Fatal error: Uncaught exception ‘Exception’ with message ‘The configuration file
{path-to-piwik/piwik/config/config.ini.php} has not been found or could not be
read.’ in path-to-piwik/piwik/core/Application/Kernel/EnvironmentValidator.ph
p:64
Stack trace:
#0 path-to-piwik/piwik/core/Application/Kernel/EnvironmentValidator.php(45): P
iwik\Application\Kernel\EnvironmentValidator->checkConfigFileExists(‘path…’, false)
#1 path-to-piwik/piwik/core/Application/Environment.php(185): Piwik\Applicatio
n\Kernel\EnvironmentValidator->validate()
#2 /path-to-piwik/piwik/core/Application/Environment.php(94): Piwik\Application
\Environment->validateEnvironment()
#3 path-to-piwik/piwik/piwik.php(56): Piwik\Application\Environment->init()
#4 {main}
thrown in path-to-piwik/piwik/core/Application/Kernel/EnvironmentValidator.p
hp on line 64
[05-Aug-2015 04:20:30] PHP Fatal error: Maximum execution time of 30 seconds exceeded in path-to-piwik/piwik/libs/Zend/Validate/Hostname.php on line 626

Would anyone know how to fix this?


(Matthieu Aubry) #2

Hello

please try to install 2.14.2 which should fix this issue and let you install Piwik :slight_smile:


#3

Thank you very much for a quick reply. In the mean time, I installed 2.13.0. Is it safe to try to update? I


(Matthieu Aubry) #4

Hi there, yes it’s safe to update


#5

Hi Matt,

I am new to piwik and tried to install the latest version(2.14.3) on my mac. I am also getting the issue, unable to proceed beyond step 3(super user) and takes back to step 1. Getting following error,

PHP Fatal error: Uncaught exception ‘Exception’ with message 'The configuration file {/Users/mbavakha/ACE_Htdocs/piwik/piwik/config/config.ini.php} has not been found or could not be read.

Please let me know how to resolve this issue.

Regards,
Mustak


(Matthieu Aubry) #6

Mustak, please try with latest beta version: download the first zip file from http://builds.piwik.org/