Can't get GeoIP server module detected in Matomo

Been messing about with GeoIP long enough now I’m starting to give up with this…

What the heck have we got to do to get this option to show as installed so we can use it?

I have already got it installed on the server as can be seen in the below…

I’ve really no idea what to do or try, I’ve read countless articles now and the own docs are pretty poor.

On the information panel is written: « Matomo cannot find any GeoIP $_SERVER variables. You can configure used server variables here »
Maybe you can check there:

Already been there and saved them with the defaults in (as none of them had been modified).

Hi @zigojacko
What is the configuration for:

(check in Administration cog>Diagnostic>Config file)

In my case, enable_internet_features is disabled, then GeoIP through HTTP can’t be activated…

Mine is enabled already…

If you don’t use GeoIP, how are you tracking what country/city a visitor is from? Or are you not?

The screenprint is on an Intranet instance of Matomo, so with no access to the internet, and no country, city, etc :wink:

1 Like

Maybe this can help you?