Can't access CorePluginsAdmin


(Dave) #1

Any time I click on the settings button i get this “You can not access this file directly!” in the page. I can navigate to the user and web sites part of the manager via the widgets, but I can not get to the plugin manager from the tab.
Any idea why it says I can not access this file? It is where the plugins are enabled, so I imagine I am supposed to be able to get to it.

Thanks,

Dave


(Matthieu Aubry) #2

what exactly is the error? The error “You can not access this file directly!” is not a piwik error.


(Dave) #3

That is all it says.
here is a screen shot.

[attachment=861:screen.png]

This is the page it sends me to after I click Settings. As far as I can tell I should be in the pluning settings page at that point in time as I get the same result when I click on the plugins tab from the websites, or user pages.


(vipsoft) #4

Login using your superuser account. Adminship only applies to administering site statistics,not your Piwik config.


(Dave) #5

The super user account? That is the one you create during setup right, that is the one I am using.

Should there be an API.php in the CorePluginsAdmin folder?


(Dave) #6

Ok, got in to the config.ini.php. I am using the superuser account, and still no results. Has no one seen this before?


(vipsoft) #7

Check your mod_rewrite/mod_security rules. That error message isn’t defined anywhere in Piwik.


(Dave) #8

Thanks for the help guys. Ended up just downloading and reinstalling via command prompt. It is working fine now. I think I may have gotten an incomplete download the first time.

Thanks again.

Dave