Cannot install on Windows


(trapias) #1

Hello,
I wish to test Piwik by installing it on a XP machine (installed XAMPP), but cannot complete the setup wizard.
After solving a first problem commeting out a line in piwik.php (see forum.piwik.org/index.php?showtopic=1324)) I can get to the db creation step, but there I alwasy get “Error while trying to connect to the database server:
No entry is registered for key ‘db’”.

No “config.ini.php” file is created in my config folder, even if I set “everyone full control” permissions on that folder - so I assume it’s not a problem with permissions.
I give root user (and correct password style_emoticons/<#EMO_DIR#>/wink.gif) to connect to mysql on the same machine.
What else to check?
Else, can anybody provide a manual installation checklist, so to skip the wizard and finally have Piwik running?

Thanks for any help,
al.


(vipsoft) #2

In xampp, the default password is blank. You’ll probably also have to use 127.0.0.1 instead of localhost.


(trapias) #3

vipsoft,
password I use is correct (updated it, and I can connect mysql with a gui client) and I’m already using the ip. I actually got an exception when using localhost, but with the ip the error is handled… just don’t know what it means style_emoticons/<#EMO_DIR#>/wink.gif
thanks anyway, will keep trying!
al.


(vipsoft) #4

Maybe it couldn’t retrieve the session info. In php.ini or .htaccess, set the session.save_path to a writable folder.


(trapias) #5

vipsoft,
I checked this, but unfortunately that’s already ok (I can see session files are created in temp directory).
Something more: I tried installing piwik on two different machines, an XP with IIS and a Win 2003 server with Xampp, but always get the same result. Also tried both mysqli and pdo connectors.
If I set “localhost” instead of 127.0.0.1 I get this exception:

PDO::__construct(): [2002] A connection attempt failed because the connected party did not (trying to connect via tcp://localhost:3306)
in ‘C:\Inetpub\wwwroot\piwik\libs\Zend\Db\Adapter\Pdo\Abstract.php’ at the line 129

But you already told me to use the ip.
Is it possible to perform a manual install, create the db and whatever is needed, bypassing the setup wizard? Or to enable some debug option in order to understand exactly where’s the problem?

Thanks again,
al.