Cannot administer piwik any longer


(sachamasry) #1

I’ve just installed Piwik on an OpenBSD 4.6 server. The Piwik is the latest svn checkout as of the 16th November.

Everything worked great initially, but after a day of tweaking the settings, it is no longer possible to go to the plugins or database usage pages in settings. Users and websites are fine.

When I click on either of these two tabs, Piwik consistently takes me to the log in page, but the link seems to be right:

…/index.php?module=CorePluginsAdmin&action=index&idSite=1&period=day&date=yesterday

There are no errors in the error logs, so I can’t work out what the problem is. Have tried multiple computers/browsers, even lynx running on the server itself, all with the same result.

Apart from that, everything runs great, but it’s a major pain not to be able to add and enable the plugins.

Can anyone help?

Sacha


(Matthieu Aubry) #2

can you still access the websites and users tab?


(sachamasry) #3

Yes. In fact, I’ve since discovered that I am actually able to get into the plugins and database statistics pages, only when logged in as the super user.

That’s cool. But what then is the purpose of the administrator then? Sorry, but I didn’t come across the distinction between administrator and super user anywhere in the documentation.

Could someone help clarify this, please? Thanks.


(Matthieu Aubry) #4

I have added FAQ to http://piwik.org/faq/general/
does it help?


(sachamasry) #5

Yeah, I understood that part. I was thinking that an administrator can/should also be able to do most of these things, too.

Through trial and error, I now understand that the administrator’s role is lesser; the admin can add sites and users, and control the users’ role, but cannot ‘administer’ the entire instance, right?

Anyway, thanks for the help, this is a fantastic product.


(Matthieu Aubry) #6

This is explained in http://piwik.org/faq/general/#faq_35