Can not sign in after upgrade to 3.0

Hi there,

after the upgrade to 3.0 yesterday I can not login to Piwik.
Piwik reports: Username and password are not correct.

Also after using the “Lost your password?” function login is not possible.
The same error ocurs. “Username and password are not correct.”

It seems so that piwik generates wrong MD5 hashes.
For example:
Password is "changeMe"
MD5 hash with piwik: $2y$10$MP4cWDvFUiG0txNR7.0VOudIo
MD5 hash with an MD5 generator: f603965f2a976b3f9b8455fa20d7897e

I try this with a few other MD5 generators, every hash is the same, but not so by piwik.

Any ideas?


SOLVED!! At least for me.

The database update from 2.17.0 to 3.0 for table “user” did not work.
The flieldtype of “password” was not changed from VAR(32) to VARCHAR(255) for crypted MD5 hash in “$2y$” format. I changed the fieldtype manually by phpMyAdmin, then I used the “Lost your password” function and generate a new password. Login is possible now.


Solved mine too but not Fieldtype Password but token_auth was still VAR(32) changed it to VARCHAR(255) and the Lost passsword option works


Ran into the same issue after upgrading to 3.0

password was at varchar(255) but not token_auth, so I changed this as suggested. However, this does not help. Password retrieval does not work either. I am lost.

Ok, I am logged in again. Clearing the browser cache obviously did not work perfectly, so a restart of the browser was the missing piece.

A bloody mess. Actually it is the “Login Http Auth” plugin causing the mess. This one is just not ready for production or whatever. Sorry for hijacking this thread and spamming it.

Did you update the LoginHttpAuth to the latest version? is it really not working for you? If so please make sure to create bug report on: Issues · matomo-org/plugin-LoginHttpAuth · GitHub