Can not create segment – no fields visible


I can not create segments because the fields for and/or are not visible, see screenshot.

I tried in Chrome, Safari and Edge with no luck.

I am using Matomo version 4.15.0


Please check your browser plug-ins and disable it temporaly.

Please check the browser inspector → source code and console and network (reload page).

1 Like

Hi melbao!

Thanks. I disables all plugin. In the inspector > Console I founded this info:

Warning: the module=Insights&action=getOverallMoversAndShakers&disableLink=0&widget=1&idSite=1&period=range request failed!

Warning: the forceView=1&viewDataTable=sparklines&module=VisitsSummary&action=get&disableLink=0&widget=1&idSite=1&period=range request failed!

Skärmavbild 2023-11-14 kl. 08.24.03

Maybe a matomo file is broken/corrupt. You can re-install your matomo installation, except the config files. Maybe this helps. For another reasons wait for an answer from @heurteph-ei .

We did a re-install, but it is still not working. Got this error message looking in the inspector.

In your first screenshot the available update is not installed. Why?

Hi! First screenshot was 4 ago and before your recommendation/answer about re-installation. I guess we could done that directly.

But an developer here installed the latest version of Matomo and then founded these error for me to share. Nothing I can do by myself since I needed help with the update, but i will remember that until next time.

Hi again!

The developer fixed this issue. He said that the config-file we had between our two servers that we have wasn’t the same. But it works now. Thank you for your help :slight_smile:

1 Like