Cache Directory Issues on New Install


#1

Hi all,

I haven’t used Piwik in a very long time but I have come back to it a couple of days ago but I have been stuck trying to install it. When I initially download and extract the files I get the following error:

Piwik couldn’t write to some directories (running as user ‘www-data’).

Try to Execute the following commands on your server, to allow Write access on these directories:

chown -R www-data:www-data /var/www/vhosts/xxxxxxx/xxxxxxx.co.uk/httpdocs/piwik
chmod -R 0755 /var/www/vhosts/xxxxxxx/xxxxxxx.co.uk/httpdocs/piwik/tmp
chmod -R 0755 /var/www/vhosts/xxxxxxx/xxxxxxx.co.uk/httpdocs/piwik/tmp/assets/
chmod -R 0755 /var/www/vhosts/xxxxxxx/xxxxxxx.co.uk/httpdocs/piwik/tmp/cache/
chmod -R 0755 /var/www/vhosts/xxxxxxx/xxxxxxx.co.uk/httpdocs/piwik/tmp/logs/
chmod -R 0755 /var/www/vhosts/xxxxxxx/xxxxxxx.co.uk/httpdocs/piwik/tmp/tcpdf/
chmod -R 0755 /var/www/vhosts/xxxxxxx/xxxxxxx.co.uk/httpdocs/piwik/tmp/templates_c/
If this doesn’t work, you can try to create the directories with your FTP software, and set the CHMOD to 0755 (or 0777 if 0755 is not enough). To do so with your FTP software, right click on the directories then click permissions.

So I follow the instructions and then I come across another issue:

Unable to create the cache directory (/var/www/vhosts/xxxxxxxxx/xxxxxxxxx.co.uk/httpdocs/piwik/tmp/templates_c/c7/fa).

and I am stumped as to where to go next. Server info:

Linux 2.6.32-042stab090.5 i686

PHP version: 5.5.9-1ubuntu4.3
MySQL version: 5.5.38
Apache version: 2.4.7 (Ubuntu)
Ubuntu 14.04


#2

This may help as I had the same problems with my own Ubuntu install and found chown/chmod just weren’t allowing me to sort out permission inheritance.

EDIT: Link lost somewhere… Re-editing
ACL fix


#3

What may help sorry


#4

Using your FTP software, you can re-name the /tmp directory to something else, such as “foo”. Then, using the FTP software, create a new /tmp directory and before launching Piwik, set the permissions on this directory to 777. Make SURE to also set the permissions on the /config directory, and all its contents, to 777.

The reason for the re-name is that you will probably not be able to delete the directory or change the permissions. You shouldn’t need to create all those subdirectories – Piwik does that automatically on an initial install, but it can do this only if the /tmp directory has 777 permissions.

This should allow Piwik to start. When the Piwik configuration is stable, check the permissions on the /config directory and, if necessary, set its permissions and that of all its contents to 755.


#5

Still getting the same result unfortunately

EDIT: Fixed it by removing the CP that I was using on the server


#6

Sorry… Didn’t realise that the link had been lost for some reason so my original post made no sense…

I’ve edited the post to include this link now…