Bug after upgrading from 0.5.2 to 0.5.3


(Analytics) #1

Hello,

after upgrading Piwik from 0.5.2 to 0.5.3 I am not able to login any more. A screenshot of the error message is attatched below. PHP Version 5.2.9-1nmm1. Please let me know if any further information is required.

Piwik # Quelloffene Webanalytik

Kritischer Fehler während dem Upgrade-Prozess:

You can now enable the new MultiSites plugin in the Plugins screen in the Piwik admin!

Das darüber ist die Kernfehlermeldung. Sie sollte die Ursache erklären, aber wenn Sie mehr erfahren wollen, helfen Sie bitte:

* Schauen Sie sich die Piwik FAQ an welche versucht, die üblichsten Fehler bei einem Upgrade zu erklären. Fragen Sie Ihre Systemadministratoren - diese könnten in der Lage sein Ihnen bei den Fehleren zu helfen welche höchstwahrscheinlich mit Ihrem Server oder der MySQL-Installation zusammenhängen.

If you are an advanced user and encounter an error in the database upgrade:

* identify and correct the source of the problem (e.g., memory_limit or max_execution_time)
* execute the remaining queries in the update that failed
* manually update the `option` table in your Piwik database, setting the value of version_core to the version of the failed update
* re-run the updater (through the browser or command-line) to continue with the remaining updates
* report the problem (and solution) so that Piwik can be improved

(vipsoft) #2

You can workaround this by either making your config.ini.php writable or removing core/Updates/0.5.3.php.

This is an optional update, so I’ve fixed this in svn so that it allows users to proceed even Piwik can’t update your config.ini.php file.


(Analytics) #3

[quote=vipsoft @ Dec 15 2009, 10:51 PM]You can workaround this by either making your config.ini.php writable or removing core/Updates/0.5.3.php.

This is an optional update, so I’ve fixed this in svn so that it allows users to proceed even Piwik can’t update your config.ini.php file.[/quote]

Thanks, worked fine.


(Marbot) #4

I had the same problem while updateing from 0.5.1 to 0.5.3. Your hint helped. Thank you!