Brand new Plesk installtion not working

I followed (so, fw is disabled also). Excetion is that I set it to root folder of subdomain, not in matomo folder.

NOTHING ELSE I TOUCHED in installation (instance).

First site I tried to add to WP site by Astra Hooks, by Insert Headers and Footers plugin, by WP-Matomo Integration plugin and neither one working, Matomo still not see the website.


Server is on GCP, Ubuntu 20.04, Plesk Click and Deploy solution and run Litespeed server.
Previously I get it working on GCP, Ubuntu 20.04, CyberPanel with OpenLiteSpeed server.

Briefly, I cannot see any structural reason to not get it work.

Any idea of issue?

Interesting. I cannot add site neither on brand new untouched installation on GCP ‘Click and Deploy’ (Official image). Simply, log to fresh installation (still IP numbers), create website, add to website code ==> nothing appear in Matomo.

What is wrong?

Is it really possible that nobody from Matomo team have any interest for fact how Official package (on GCP) and Plesk manual installation doesn’t work at all?


Which “Official package” are you referring to?

Matomo works on any PHP/Webserver/MySQL setup, no matter if you set it up using Plesk or anything else.

If no data shows up in Matomo after adding your tracking code to the website, check if the tracking code works correctly. E.g. by opening your browsers developer tools on the tracked site and checking if the requests to matomo.js and matomo.php are successful.

  1. If this is ( not a Matomo official package (mean, packed by Matomo), I’m apologize.

However, I mention it as it should to work “out of box” without any settings (and it did in previous installation).

  1. I already wrote that I get Matomo before. So, YES, developer tools in browser show in order matomo.js like Source in Debugger tab.


It seems like that image is maintained by Google and not the Matomo team.

You can try to (temporarily) enable

This makes Matomo respond to the matomo.php request with a verbose log on why the request was (not) stored.

Well … here we have some small problems. I can add it (I did, at bottom of file):

debug = 1
enable_sql_profiler = 1
debug_on_demand = 1

However, I have no idea what to do with that. I suggest (if it could be potential bug, and it is weird that it is same for GCP Click to Deploy and on Plesk), Matomo probably should to have interest to see what is the possible reason.

So, as currently I have testing Matomo instance on my testing purpose domain and testing WP instance (both on same Plesk), I can create Customer account for you and send you credentials for Customer Plesk panel to get full access to both instances (including ssh and file access. Then you should quickly see what could be problem. If you agree, I can send you on GitHub private message with credentials, if you agree to see this issue.


If you leave out the line with debug_on_demand then you can now check your developer tools on the tracked website and the matomo.php request in the network tab should show a response with a detailed log.

I wrote that I have no idea for what to looking for. Testing instances are at and

When you open your website Matomo makes a request to

If you open this URL directly, you can see the log of what Matomo does.

For me it shows Inserted new action, so my visit should show up in Matomo for you.

When I visit the page with my regular browser I get

[2021-04-07 17:01:33] piwik.DEBUG: DoNotTrack header found! [] {"class":"PrivacyManager","request_id":"1498d"}

[2021-04-07 17:01:33] piwik.DEBUG: Visitor excluded. [] {"class":"CoreHome","request_id":"1498d"}

[2021-04-07 17:01:33] piwik.DEBUG: -> aborting due to processRequestParams method [] {"class":"Piwik\\Common","request_id":"1498d"}

as I have DNT enabled in my browser and Matomo respects that and doesn’t store the visit.

OK, I get you, but slightly confused. I mean, now dialog disappeared. So, entire issue is that my visits in Opera VPN this time didn’t worked for me. Thanks for help.