because installed bot tracker, don`t want to recognize bots, i try to install:

but got this error when go to activate plugin:

There was a problem installing the plugin BotTracker: SQLSTATE[42S02]: Base table or view not found: 1051 Unknown table ‘stats_bot_db’ If this plugin has already been installed, and if you want to hide this message, you must add the following line under the [PluginsInstalled] entry in your config/config.ini.php file: PluginsInstalled[] = BotTracker

and yes, i dont have that table, in downloaded files adn dont have any file where is sql tables.

Please help.

I also tried to install BotTracker -
first I found only the old version 0.10 … ok,

then with 0.21,

Download, Dezip, upload into Plugins with Original Plugin-Name,
login into Piwik, and try to activate - Mistake, breaks all

no more using of Piwik,
so handmade delete the entries of config-file,

restart ok …

check at database, nothing inside (the piwik_bot_…),

so I took out the create database routine, OK
then i took out the update database - also ok
I got some data in …

when aktivate the Plugin again, mistake with like double idsite 447 …
(is two days ago, and I had others to do …then Screenshots …)

Any Solution until now, same Problem … ?

Me seams the Routine to activate is not running …
but if I do handmade - also don’t like it …

Greetings from Thailand

Sorry for the late reply. I but found your post just today…

Have you tried a clean install of 0.22?

You have to drop the table “piwik_bot_db”, remove the folder “plugins/BotTracker” and delete alle rows in “config/config.ini.php” with “BotTracker”.
Then install the new version.

If you get an error during activation please post it here or in the plugin-ticket: Plugin: BotTracker to track bot-actions · Issue #2391 · matomo-org/matomo · GitHub

Good Luck :wink:


Hey, Your using Tracker Bot ? I mean The app is not free and also
Unwanted altcoins added that have less market life. Would you suggest using it ?

The app is free:

But it is broken unless you manually remove the robots.txt that is present since Matomo v4:

But even when doing that, Google and Bing crawlers fail to call the tracker backend, while other crawlers succeed. I want to investigate now why: Google and Bing crawlers fail to call the tracker endpoint